# CVE-2026-27818: TerriaJS-Server has a domain validation bypass vulnerability in its proxy allowlist

> An attacker can bypass proxy allowlist restrictions to access unauthorized domains, potentially reading internal data.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Feb 2026
- **Updated:** 26 Feb 2026
- **Also known as:** GHSA-w789-49fc-v8hr

## What is CVE-2026-27818?

CVE-2026-27818 is a high-severity server-side request forgery vulnerability in terriajs-server, published on 26 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

TerriaJS-Server is a NodeJS Express server for TerriaJS, a library for building web-based geospatial data explorers. A validation bug in versions prior to 4.0.3 allows an attacker to proxy domains not explicitly allowed in the `proxyableDomains` configuration. Version 4.0.3 fixes the issue.

Weakness: CWE-918 (Server-Side Request Forgery), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-27818?

2 open source packages ship an affected version, including terriajs-server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `terriajs-server` | npm | All versions | 4.0.3 |
| `terriajs-server` | npm | All versions | 4.0.3 |

Products: Terria Terriajs-Server.

## How do I fix CVE-2026-27818?

Upgrade terriajs-server to 4.0.3 or later.

## Is CVE-2026-27818 being exploited?

There is no known exploitation of CVE-2026-27818 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-27818 and fix it if it is affected.

What it is: CVE-2026-27818 is a high-severity server-side request forgery vulnerability in terriajs-server, published on 26 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-27818 in the wild and no public exploit code.

Affected packages and fixed versions:
- terriajs-server (npm): affected all versions; fixed in 4.0.3
- terriajs-server (npm): affected all versions; fixed in 4.0.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-27818/ (Markdown: https://insights.sbomify.com/CVE-2026-27818/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-27818
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-27818
- OSV: https://osv.dev/vulnerability/CVE-2026-27818

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-27818/
Summaries are generated and may contain mistakes; the official description above is the record.
