{"answers":{"affected":"6 open source packages ship an affected version, including zlib. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-27820 in the wild and no public exploit code.","fix":"Upgrade zlib to a fixed version for your release line: 3.0.1, 3.1.2 or 3.2.3.","what":"CVE-2026-27820 is a low-severity memory corruption vulnerability in ruby zlib, published on 16 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-27820 and fix it if it is affected.\n\nWhat it is: CVE-2026-27820 is a low-severity memory corruption vulnerability in ruby zlib, published on 16 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-27820 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- zlib (RubyGems): affected all versions; fixed in 3.0.1\n- zlib (RubyGems): affected all versions; fixed in 3.0.1\n- zlib (RubyGems): affected from 3.1.0; fixed in 3.1.2\n- zlib (RubyGems): affected from 3.1.0; fixed in 3.1.2\n- zlib (RubyGems): affected from 3.2.0; fixed in 3.2.3\n- zlib (RubyGems): affected from 3.2.0; fixed in 3.2.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-27820/ (Markdown: https://insights.sbomify.com/CVE-2026-27820/index.md)","id":"CVE-2026-27820","markdown":"https://insights.sbomify.com/CVE-2026-27820/index.md","name":"CVE-2026-27820","record":{"aliases":["ALPINE-CVE-2026-27820","AZL-83450","BELL-CVE-2026-27820","CLSA-2026-1785320518","CLSA-2026-1785428387","CLSA-2026-1786470325","DEBIAN-CVE-2026-27820","ECHO-cdf4-0e18-2536","GHSA-g857-hhfv-j68w","MINI-32p3-2876-68mf","MINI-74xg-wvvm-42c4","MINI-7qgg-79gq-6x4r","MINI-f9f6-rfc4-f8vg","MINI-fg53-wx78-hrqc","MINI-fpw6-8v58-wwx9","UBUNTU-CVE-2026-27820"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby zlib library","requires_auth":"none","summary":"A buffer overflow in the Ruby zlib library allows attackers to cause memory corruption and potentially execute code via crafted gzip input.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"zlib","vendor":"ruby-lang"}],"cvss":{"score":1.7,"severity":"low","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:U","version":"4.0"},"cwes":[{"id":"CWE-131","name":"Incorrect Calculation of Buffer Size"},{"id":"CWE-120","name":"Buffer Copy without Checking Size of Input"}],"description":"zlib is a Ruby interface for the zlib compression/decompression library. Versions 3.0.0 and below, 3.1.0, 3.1.1, 3.2.0 and 3.2.1 contain a buffer overflow vulnerability in the Zlib::GzipReader. The zstream_buffer_ungets function prepends caller-provided bytes ahead of previously produced output but fails to guarantee the backing Ruby string has enough capacity before the memmove shifts the existing data. This can lead to memory corruption when the buffer length exceeds capacity. This issue has been fixed in versions 3.0.1, 3.1.2 and 3.2.3.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"zlib: Buffer Overflow in Zlib::GzipReader ungetc via large input leads to memory corruption","id":"CVE-2026-27820","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"memory_corruption","year":"2026"},"n_packages":6,"n_references":2,"next":{"headline":"GPAC NHML Demuxer (dmx_nhml.c) Vulnerable to Stack Buffer Overflow","id":"CVE-2026-27821"},"packages":[{"ecosystem":"RubyGems","fixed":["3.0.1"],"introduced":["0"],"last_affected":[],"package":"zlib","purl":null,"source":"GHSA-g857-hhfv-j68w"},{"ecosystem":"RubyGems","fixed":["3.0.1"],"introduced":["0"],"last_affected":[],"package":"zlib","purl":"pkg:gem/zlib","source":"GHSA-g857-hhfv-j68w"},{"ecosystem":"RubyGems","fixed":["3.1.2"],"introduced":["3.1.0"],"last_affected":[],"package":"zlib","purl":null,"source":"GHSA-g857-hhfv-j68w"},{"ecosystem":"RubyGems","fixed":["3.1.2"],"introduced":["3.1.0"],"last_affected":[],"package":"zlib","purl":"pkg:gem/zlib","source":"GHSA-g857-hhfv-j68w"},{"ecosystem":"RubyGems","fixed":["3.2.3"],"introduced":["3.2.0"],"last_affected":[],"package":"zlib","purl":null,"source":"GHSA-g857-hhfv-j68w"},{"ecosystem":"RubyGems","fixed":["3.2.3"],"introduced":["3.2.0"],"last_affected":[],"package":"zlib","purl":"pkg:gem/zlib","source":"GHSA-g857-hhfv-j68w"}],"prev":{"headline":"Vikunja has Path Traversal in CLI Restore","id":"CVE-2026-27819"},"products":["zlib"],"published":"2026-04-16","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-04-16","vendors":["ruby"]},"summary":"A buffer overflow in the Ruby zlib library allows attackers to cause memory corruption and potentially execute code via crafted gzip input.","url":"https://insights.sbomify.com/CVE-2026-27820/"}