# CVE-2026-27836: phpMyFAQ Allows Unauthenticated Account Creation via WebAuthn Prepare Endpoint

> Unauthenticated attackers can create unlimited user accounts via the WebAuthn prepare endpoint, bypassing registration restrictions in phpMyFAQ.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Feb 2026
- **Updated:** 3 Mar 2026
- **Also known as:** GHSA-w22q-m2fm-x9f4

## What is CVE-2026-27836?

CVE-2026-27836 is a high-severity missing authorization vulnerability in Phpmyfaq Phpmyfaq, published on 27 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

phpMyFAQ is an open source FAQ web application. Prior to version 4.0.18, the WebAuthn prepare endpoint (`/api/webauthn/prepare`) creates new active user accounts without any authentication, CSRF protection, captcha, or configuration checks. This allows unauthenticated attackers to create unlimited user accounts even when registration is disabled. Version 4.0.18 fixes the issue.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-27836?

2 open source packages ship an affected version, including thorsten/phpmyfaq. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `thorsten/phpmyfaq` | Packagist | All versions | 4.0.18 |
| `thorsten/phpmyfaq` | Packagist | All versions | 4.0.18 |

Products: Phpmyfaq Phpmyfaq.

## How do I fix CVE-2026-27836?

Upgrade thorsten/phpmyfaq to 4.0.18 or later.

## Is CVE-2026-27836 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-27836 exists.

## Other vulnerabilities in Phpmyfaq Phpmyfaq

- [CVE-2023-0310](https://insights.sbomify.com/CVE-2023-0310/): Cross-site Scripting (XSS) - Stored in thorsten/phpmyfaq (critical 9.8)
- [CVE-2022-4407](https://insights.sbomify.com/CVE-2022-4407/): Cross-site Scripting (XSS) - Reflected in thorsten/phpmyfaq (critical 9.8)
- [CVE-2017-11187](https://insights.sbomify.com/CVE-2017-11187/): Security feature bypass in n/a (critical 9.8)
- [CVE-2026-76213](https://insights.sbomify.com/CVE-2026-76213/): phpMyFAQ before 4.1.7 2FA Brute-Force via Session-Scoped Throttle (critical 9.1)
- [CVE-2026-76214](https://insights.sbomify.com/CVE-2026-76214/): phpMyFAQ before 4.1.7 WebAuthn Replay Attack via Challenge (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-27836 and fix it if it is affected.

What it is: CVE-2026-27836 is a high-severity missing authorization vulnerability in Phpmyfaq Phpmyfaq, published on 27 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-27836 exists.

Affected packages and fixed versions:
- thorsten/phpmyfaq (Packagist): affected all versions; fixed in 4.0.18
- thorsten/phpmyfaq (Packagist): affected all versions; fixed in 4.0.18

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-27836/ (Markdown: https://insights.sbomify.com/CVE-2026-27836/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-27836
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-27836
- OSV: https://osv.dev/vulnerability/CVE-2026-27836

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-27836/
Summaries are generated and may contain mistakes; the official description above is the record.
