# CVE-2026-27884: NetExec vulnerable to arbitrary file write via path traversal in spider_plus module

> Attackers can write or overwrite arbitrary files via path traversal in SMB filenames when using the spider_plus module with download enabled.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 26 Feb 2026
- **Updated:** 26 Feb 2026
- **Also known as:** GHSA-fccr-6qm2-7h27

## What is CVE-2026-27884?

CVE-2026-27884 is a medium-severity path traversal vulnerability in Pennyw0rth NetExec, published on 26 Feb 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

NetExec is a network execution tool. Prior to version 1.5.1, the module spider_plus improperly creates the output file and folder path when saving files from SMB shares. It does not take into account that it is possible for Linux SMB shares to have path traversal characters such as `../` in them. An attacker can craft a filename in an SMB share that includes these characters, which when spider_plus crawls and downloads, can write or overwrite arbitrary files. The issue is patched in v1.5.1. As a workaround, do not run spider_plus with DOWNLOAD=true against targets.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-27884?


## How do I fix CVE-2026-27884?

No fix has been published for CVE-2026-27884 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-27884 being exploited?

There is no known exploitation of CVE-2026-27884 in the wild and no public exploit code.

Public exploit code:

- https://github.com/RaynLight/CVE-2026-27884 (github_poc): https://github.com/RaynLight/CVE-2026-27884

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-27884 and fix it if it is affected.

What it is: CVE-2026-27884 is a medium-severity path traversal vulnerability in Pennyw0rth NetExec, published on 26 Feb 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-27884 in the wild and no public exploit code.

Affected product: Pennyw0rth NetExec. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-27884/ (Markdown: https://insights.sbomify.com/CVE-2026-27884/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-27884
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-27884
- OSV: https://osv.dev/vulnerability/CVE-2026-27884

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-27884/
Summaries are generated and may contain mistakes; the official description above is the record.
