# CVE-2026-27890: Firebird has Pre-Auth DOS when Processing Out of Order CNCT_specific_data Segments

> An unauthenticated attacker can crash the Firebird database server by sending out-of-order authentication segments, causing a segmentation fault.

- **Severity:** High 8.2 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Apr 2026
- **Updated:** 17 Apr 2026
- **Also known as:** DEBIAN-CVE-2026-27890, ECHO-45ec-b367-e096, GHSA-6crx-4g37-7j49, UBUNTU-CVE-2026-27890

## What is CVE-2026-27890?

CVE-2026-27890 is a high-severity denial of service vulnerability in FirebirdSQL firebird, published on 17 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Firebird is an open-source relational database management system. In versions prior to 5.0.4, 4.0.7 and 3.0.14, when processing CNCT_specific_data segments during authentication, the server assumes segments arrive in strictly ascending order. If segments arrive out of order, the Array class's grow() method computes a negative size value, causing a SIGSEGV crash. An unauthenticated attacker who knows only the server's IP and port can exploit this to crash the server. This issue has been fixed in versions 5.0.4, 4.0.7 and 3.0.14.

Weakness: CWE-787 (Out-of-bounds Write), CWE-119 (Improper Restriction of Operations within the Bounds of a Memory Buffer)

## Which versions are affected by CVE-2026-27890?

It affects 1 product.


Products: Firebirdsql Firebird.

## How do I fix CVE-2026-27890?

Upgrade to a fixed version.

## Is CVE-2026-27890 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-27890 exists.

## Other vulnerabilities in FirebirdSQL firebird

- [CVE-2026-40342](https://insights.sbomify.com/CVE-2026-40342/): Firebird: Path Traversal + Arbitrary File Write Leads to Remote Code Execution (critical 10.0)
- [CVE-2008-0467](https://insights.sbomify.com/CVE-2008-0467/): Memory corruption in n/a (critical 10.0)
- [CVE-2007-4992](https://insights.sbomify.com/CVE-2007-4992/): Memory corruption in n/a (critical 10.0)
- [CVE-2007-5245](https://insights.sbomify.com/CVE-2007-5245/): Memory corruption in n/a (critical 10.0)
- [CVE-2007-5246](https://insights.sbomify.com/CVE-2007-5246/): Memory corruption in n/a (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-27890 and fix it if it is affected.

What it is: CVE-2026-27890 is a high-severity denial of service vulnerability in FirebirdSQL firebird, published on 17 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-27890 exists.

Affected product: FirebirdSQL firebird. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-27890/ (Markdown: https://insights.sbomify.com/CVE-2026-27890/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-27890
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-27890
- OSV: https://osv.dev/vulnerability/CVE-2026-27890

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-27890/
Summaries are generated and may contain mistakes; the official description above is the record.
