{"answers":{"affected":"3 open source packages ship an affected version, including vllm. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-27893 in the wild and no public exploit code.","fix":"Upgrade vllm to 0.18.0 or later.","what":"CVE-2026-27893 is a high-severity code injection vulnerability in Vllm Vllm, published on 26 Mar 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-27893 and fix it if it is affected.\n\nWhat it is: CVE-2026-27893 is a high-severity code injection vulnerability in Vllm Vllm, published on 26 Mar 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-27893 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- vllm (PyPI): affected from 0.10.1; fixed in 0.18.0\n- vllm (PyPI): affected from 0.10.1; fixed in 0.18.0\n- vllm (PyPI): affected from 0.10.1; fixed in 0.18.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-27893/ (Markdown: https://insights.sbomify.com/CVE-2026-27893/index.md)","id":"CVE-2026-27893","markdown":"https://insights.sbomify.com/CVE-2026-27893/index.md","name":"CVE-2026-27893","record":{"aliases":["GHSA-7972-pg2x-xr59","PYSEC-2026-2297"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"LLM inference engine","requires_auth":"none","summary":"Attackers can execute arbitrary code via malicious models because vLLM ignores the user's disabled remote code trust setting.","user_interaction":"required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"vllm","vendor":"vllm"}],"cvss":{"score":8.8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-501","name":"Trust Boundary Violation"},{"id":"CWE-693","name":"Protection Mechanism Failure"}],"description":"vLLM is an inference and serving engine for large language models (LLMs). Starting in version 0.10.1 and prior to version 0.18.0, two model implementation files hardcode `trust_remote_code=True` when loading sub-components, bypassing the user's explicit `--trust-remote-code=False` security opt-out. This enables remote code execution via malicious model repositories even when the user has explicitly disabled remote code trust. Version 0.18.0 patches the issue.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"vLLM's hardcoded trust_remote_code=True in NemotronVL and KimiK25 bypasses user security opt-out","id":"CVE-2026-27893","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":"vllm:vllm","products":["vllm:vllm"],"type":"code_injection","year":"2026"},"n_packages":3,"n_references":3,"next":{"headline":"LAM has Authenticated Local File Inclusion (LFI) in PDF export","id":"CVE-2026-27894"},"packages":[{"ecosystem":"PyPI","fixed":["0.18.0"],"introduced":["0.10.1"],"last_affected":[],"package":"vllm","purl":null,"source":"GHSA-7972-pg2x-xr59"},{"ecosystem":"PyPI","fixed":["0.18.0"],"introduced":["0.10.1"],"last_affected":[],"package":"vllm","purl":"pkg:pypi/vllm","source":"GHSA-7972-pg2x-xr59"},{"ecosystem":"PyPI","fixed":["0.18.0"],"introduced":["0.10.1"],"last_affected":[],"package":"vllm","purl":"pkg:pypi/vllm","source":"PYSEC-2026-2297"}],"prev":{"headline":"FacturaScripts: Unstripped Image Metadata (EXIF) Leakage via Library Module File Upload/Download","id":"CVE-2026-27892"},"products":["vllm"],"published":"2026-03-26","related":[{"cvss_score":10,"headline":"vLLM Vulnerable to Remote Code Execution via Mooncake Integration","id":"CVE-2025-32444","kev_date_added":null,"published":"2025-04-30"},{"cvss_score":9.8,"headline":"vLLM leaks a heap address when PIL throws an error","id":"CVE-2026-22778","kev_date_added":null,"published":"2026-02-02"},{"cvss_score":9.8,"headline":"vLLM Allows Remote Code Execution via PyNcclPipe Communication Service","id":"CVE-2025-47277","kev_date_added":null,"published":"2025-05-20"},{"cvss_score":9.8,"headline":"Remote Code Execution in vllm-project/vllm","id":"CVE-2024-11041","kev_date_added":null,"published":"2025-03-20"},{"cvss_score":9.1,"headline":"vLLM: OpenAI auth bypass","id":"CVE-2026-48746","kev_date_added":null,"published":"2026-06-22"},{"cvss_score":9.1,"headline":"vLLM Allows Remote Code Execution via Mooncake Integration","id":"CVE-2025-29783","kev_date_added":null,"published":"2025-03-19"},{"cvss_score":8.8,"headline":"vLLM 0.9.2 before 0.24.0 SSRF via X-Request-Id in P2pNcclConnector","id":"CVE-2026-116176","kev_date_added":null,"published":"2026-10-25"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-07-27","vendors":["vllm-project"]},"summary":"Attackers can execute arbitrary code via malicious models because vLLM ignores the user's disabled remote code trust setting.","url":"https://insights.sbomify.com/CVE-2026-27893/"}