# CVE-2026-27893: vLLM's hardcoded trust_remote_code=True in NemotronVL and KimiK25 bypasses user security opt-out

> Attackers can execute arbitrary code via malicious models because vLLM ignores the user's disabled remote code trust setting.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 26 Mar 2026
- **Updated:** 27 Jul 2026
- **Also known as:** GHSA-7972-pg2x-xr59, PYSEC-2026-2297

## What is CVE-2026-27893?

CVE-2026-27893 is a high-severity code injection vulnerability in Vllm Vllm, published on 26 Mar 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

vLLM is an inference and serving engine for large language models (LLMs). Starting in version 0.10.1 and prior to version 0.18.0, two model implementation files hardcode `trust_remote_code=True` when loading sub-components, bypassing the user's explicit `--trust-remote-code=False` security opt-out. This enables remote code execution via malicious model repositories even when the user has explicitly disabled remote code trust. Version 0.18.0 patches the issue.

Weakness: CWE-501 (Trust Boundary Violation), CWE-693 (Protection Mechanism Failure)

## Which versions are affected by CVE-2026-27893?

3 open source packages ship an affected version, including vllm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vllm` | PyPI | From 0.10.1 | 0.18.0 |
| `vllm` | PyPI | From 0.10.1 | 0.18.0 |
| `vllm` | PyPI | From 0.10.1 | 0.18.0 |

Products: Vllm Vllm.

## How do I fix CVE-2026-27893?

Upgrade vllm to 0.18.0 or later.

## Is CVE-2026-27893 being exploited?

There is no known exploitation of CVE-2026-27893 in the wild and no public exploit code.

## Other vulnerabilities in Vllm Vllm

- [CVE-2025-32444](https://insights.sbomify.com/CVE-2025-32444/): vLLM Vulnerable to Remote Code Execution via Mooncake Integration (critical 10.0)
- [CVE-2026-22778](https://insights.sbomify.com/CVE-2026-22778/): vLLM leaks a heap address when PIL throws an error (critical 9.8)
- [CVE-2025-47277](https://insights.sbomify.com/CVE-2025-47277/): vLLM Allows Remote Code Execution via PyNcclPipe Communication Service (critical 9.8)
- [CVE-2024-11041](https://insights.sbomify.com/CVE-2024-11041/): Remote Code Execution in vllm-project/vllm (critical 9.8)
- [CVE-2026-48746](https://insights.sbomify.com/CVE-2026-48746/): vLLM: OpenAI auth bypass (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-27893 and fix it if it is affected.

What it is: CVE-2026-27893 is a high-severity code injection vulnerability in Vllm Vllm, published on 26 Mar 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-27893 in the wild and no public exploit code.

Affected packages and fixed versions:
- vllm (PyPI): affected from 0.10.1; fixed in 0.18.0
- vllm (PyPI): affected from 0.10.1; fixed in 0.18.0
- vllm (PyPI): affected from 0.10.1; fixed in 0.18.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-27893/ (Markdown: https://insights.sbomify.com/CVE-2026-27893/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-27893
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-27893
- OSV: https://osv.dev/vulnerability/CVE-2026-27893

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-27893/
Summaries are generated and may contain mistakes; the official description above is the record.
