# CVE-2026-27900: Terraform Provider Debug Logs Vulnerable to Sensitive Information Exposure

> Attackers with log access can extract sensitive credentials and data from Terraform Linode provider debug logs when logging is enabled.

- **Severity:** Medium 5.0 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Feb 2026
- **Updated:** 26 Feb 2026
- **Also known as:** GHSA-5rc7-2jj6-mp64, GO-2026-4562

## What is CVE-2026-27900?

CVE-2026-27900 is a medium-severity vulnerability in terraform-provider-linode, published on 26 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The Terraform Provider for Linode versions prior to v3.9.0 logged sensitive information including some passwords, StackScript content, and object storage data in debug logs without redaction. Provider debug logging is not enabled by default. This issue is exposed when debug/provider logs are explicitly enabled (for example in local troubleshooting, CI/CD jobs, or centralized log collection). If enabled, sensitive values may be written to logs and then retained, shared, or exported beyond the original execution environment. An authenticated user with access to provider debug logs (through log aggregation systems, CI/CD pipelines, or debug output) would thus be able to extract these sensitive credentials. Versions 3.9.0 and later sanitize debug logs by logging only non-sensitive metadata such as labels, regions, and resource IDs while redacting credentials, tokens, keys, scripts, and other sensitive content. Some other mitigations and workarounds are available. Disable Terraform/provider debug logging or set it to `WARN` level or above, restrict access to existing and historical logs, purge/retention-trim logs that may contain sensitive values, and/or rotate potentially exposed secrets/credentials.

Weakness: CWE-532 (Insertion of Sensitive Information into Log File)

## Which versions are affected by CVE-2026-27900?

9 open source packages ship an affected version, including github.com/linode/terraform-provider-linode, github.com/linode/terraform-provider-linode/v2 and github.com/linode/terraform-provider-linode/v3. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/linode/terraform-provider-linode` | Go | All versions | None |
| `github.com/linode/terraform-provider-linode` | Go | All versions to 1.30.0 | None |
| `github.com/linode/terraform-provider-linode` | Go | All versions to 1.30.0 | None |
| `github.com/linode/terraform-provider-linode/v2` | Go | All versions | None |
| `github.com/linode/terraform-provider-linode/v2` | Go | All versions to 2.41.2 | None |
| `github.com/linode/terraform-provider-linode/v2` | Go | All versions to 2.41.2 | None |
| `github.com/linode/terraform-provider-linode/v3` | Go | All versions | 3.9.0 |
| `github.com/linode/terraform-provider-linode/v3` | Go | All versions | 3.9.0 |
| `github.com/linode/terraform-provider-linode/v3` | Go | All versions | 3.9.0 |

Products: Terraform Linode Provider.

## How do I fix CVE-2026-27900?

Upgrade to a fixed version.

## Is CVE-2026-27900 being exploited?

There is no known exploitation of CVE-2026-27900 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-27900 and fix it if it is affected.

What it is: CVE-2026-27900 is a medium-severity vulnerability in terraform-provider-linode, published on 26 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-27900 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/linode/terraform-provider-linode (Go): affected all versions; no fix listed
- github.com/linode/terraform-provider-linode (Go): affected all versions up to 1.30.0; no fix listed
- github.com/linode/terraform-provider-linode (Go): affected all versions up to 1.30.0; no fix listed
- github.com/linode/terraform-provider-linode/v2 (Go): affected all versions; no fix listed
- github.com/linode/terraform-provider-linode/v2 (Go): affected all versions up to 2.41.2; no fix listed
- github.com/linode/terraform-provider-linode/v2 (Go): affected all versions up to 2.41.2; no fix listed
- github.com/linode/terraform-provider-linode/v3 (Go): affected all versions; fixed in 3.9.0
- github.com/linode/terraform-provider-linode/v3 (Go): affected all versions; fixed in 3.9.0
- github.com/linode/terraform-provider-linode/v3 (Go): affected all versions; fixed in 3.9.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-27900/ (Markdown: https://insights.sbomify.com/CVE-2026-27900/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-27900
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-27900
- OSV: https://osv.dev/vulnerability/CVE-2026-27900

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-27900/
Summaries are generated and may contain mistakes; the official description above is the record.
