# CVE-2026-27902: Svelte Vulnerable to XSS via HTML Comment Injection in SSR Error Boundary Hydration Markers

> Attackers can inject malicious scripts via unescaped error messages in Svelte SSR hydration markers, leading to XSS.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:P/VC:L/VI:N/VA:N/SC:H/SI:H/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 26 Feb 2026
- **Updated:** 26 Feb 2026
- **Also known as:** GHSA-qgvg-pr8v-6rr3

## What is CVE-2026-27902?

CVE-2026-27902 is a medium-severity cross-site scripting vulnerability in sveltejs svelte, published on 26 Feb 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Svelte performance oriented web framework. Prior to version 5.53.5, errors from `transformError` were not correctly escaped prior to being embedded in the HTML output, causing potential HTML injection and XSS if attacker-controlled content is returned from `transformError`. Version 5.53.5 fixes the issue.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-27902?

2 open source packages ship an affected version, including svelte. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `svelte` | npm | From 5.53.0 | 5.53.5 |
| `svelte` | npm | From 5.53.0 | 5.53.5 |

Products: Svelte Svelte.

## How do I fix CVE-2026-27902?

Upgrade svelte to 5.53.5 or later.

## Is CVE-2026-27902 being exploited?

There is no known exploitation of CVE-2026-27902 in the wild and no public exploit code.

## Other vulnerabilities in sveltejs svelte

- [CVE-2021-29261](https://insights.sbomify.com/CVE-2021-29261/): Code injection in n/a (high 7.8)
- [CVE-2026-42567](https://insights.sbomify.com/CVE-2026-42567/): Svelte: ReDoS in `<svelte:element>` Tag Validation (medium 5.9)
- [CVE-2024-45047](https://insights.sbomify.com/CVE-2024-45047/): Potential mXSS vulnerability due to improper HTML escaping in svelte (medium 5.4)
- [CVE-2022-25875](https://insights.sbomify.com/CVE-2022-25875/): Cross-site Scripting (XSS) (medium 5.4)
- [CVE-2026-42573](https://insights.sbomify.com/CVE-2026-42573/): Svelte: XSS via DOM Clobbering of Internal Framework State (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-27902 and fix it if it is affected.

What it is: CVE-2026-27902 is a medium-severity cross-site scripting vulnerability in sveltejs svelte, published on 26 Feb 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-27902 in the wild and no public exploit code.

Affected packages and fixed versions:
- svelte (npm): affected from 5.53.0; fixed in 5.53.5
- svelte (npm): affected from 5.53.0; fixed in 5.53.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-27902/ (Markdown: https://insights.sbomify.com/CVE-2026-27902/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-27902
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-27902
- OSV: https://osv.dev/vulnerability/CVE-2026-27902

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-27902/
Summaries are generated and may contain mistakes; the official description above is the record.
