CVE-2026-27903 minimatch has a ReDoS: matchOne() combinatorial backtracking via multiple non-adjacent GLOBSTAR segments

High 7.5 Published Updated

Attackers can cause denial of service in applications using minimatch by supplying crafted glob patterns that trigger excessive backtracking.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-27903?

CVE-2026-27903 is a high-severity denial of service vulnerability in isaacs minimatch, published on 26 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

minimatch is a minimal matching utility for converting glob expressions into JavaScript RegExp objects. Prior to version 10.2.3, 9.0.7, 8.0.6, 7.4.8, 6.2.2, 5.1.8, 4.2.5, and 3.1.3, `matchOne()` performs unbounded recursive backtracking when a glob pattern contains multiple non-adjacent `**` (GLOBSTAR) segments and the input path does not match. The time complexity is O(C(n, k)) -- binomial -- where `n` is the number of path segments and `k` is the number of globstars. With k=11 and n=30, a call to the default `minimatch()` API stalls for roughly 5 seconds. With k=13, it exceeds 15 seconds. No memoization or call budget exists to bound this behavior. Any application where an attacker can influence the glob pattern passed to `minimatch()` is vulnerable. The realistic attack surface includes build tools and task runners that accept user-supplied glob arguments (ESLint, Webpack, Rollup config), multi-tenant systems where one tenant configures glob-based rules that run in a shared process, admin or developer interfaces that accept ignore-rule or filter configuration as globs, and CI/CD pipelines that evaluate user-submitted config files containing glob patterns. An attacker who can place a crafted pattern into any of these paths can stall the Node.js event loop for tens of seconds per invocation. The pattern is 56 bytes for a 5-second stall and does not require authentication in contexts where pattern input is part of the feature. Versions 10.2.3, 9.0.7, 8.0.6, 7.4.8, 6.2.2, 5.1.8, 4.2.5, and 3.1.3 fix the issue.

Weakness: CWE-407

Which versions are affected by CVE-2026-27903?

16 open source packages ship an affected version, including minimatch. It affects 1 product.

PackageAffectedFixed in
minimatch npmAll versions3.1.3
minimatch npmAll versions3.1.3
minimatch npmFrom 10.0.010.2.3
minimatch npmFrom 10.0.010.2.3
minimatch npmFrom 4.0.04.2.5
minimatch npmFrom 4.0.04.2.5
10 more packages
minimatch npmFrom 5.0.05.1.8
minimatch npmFrom 5.0.05.1.8
minimatch npmFrom 6.0.06.2.2
minimatch npmFrom 6.0.06.2.2
minimatch npmFrom 7.0.07.4.8
minimatch npmFrom 7.0.07.4.8
minimatch npmFrom 8.0.08.0.6
minimatch npmFrom 8.0.08.0.6
minimatch npmFrom 9.0.09.0.7
minimatch npmFrom 9.0.09.0.7

Products include Minimatch Project Minimatch.

How do I fix CVE-2026-27903?

Upgrade minimatch to a fixed version for your release line: 3.1.3, 10.2.3, 4.2.5 or 5.1.8.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2026-27903 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-27903 exists.

Sources

Also known as AZL-101105, AZL-101108, AZL-101769, CLEANSTART-2026-BZ42078, CLEANSTART-2026-KL34343, CLEANSTART-2026-TV52514 and 51 more.

Is CVE-2026-27903 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free