CVE-2026-27904 minimatch ReDoS: nested *() extglobs generate catastrophically backtracking regular expressions
Attackers can cause denial of service in applications using minimatch by providing crafted glob patterns that trigger catastrophic backtracking.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-27904?
CVE-2026-27904 is a high-severity denial of service vulnerability in isaacs minimatch, published on 26 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
minimatch is a minimal matching utility for converting glob expressions into JavaScript RegExp objects. Prior to version 10.2.3, 9.0.7, 8.0.6, 7.4.8, 6.2.2, 5.1.8, 4.2.5, and 3.1.4, nested `*()` extglobs produce regexps with nested unbounded quantifiers (e.g. `(?:(?:a|b)*)*`), which exhibit catastrophic backtracking in V8. With a 12-byte pattern `*(*(*(a|b)))` and an 18-byte non-matching input, `minimatch()` stalls for over 7 seconds. Adding a single nesting level or a few input characters pushes this to minutes. This is the most severe finding: it is triggered by the default `minimatch()` API with no special options, and the minimum viable pattern is only 12 bytes. The same issue affects `+()` extglobs equally. Versions 10.2.3, 9.0.7, 8.0.6, 7.4.8, 6.2.2, 5.1.8, 4.2.5, and 3.1.4 fix the issue.
Weakness: CWE-1333
Which versions are affected by CVE-2026-27904?
16 open source packages ship an affected version, including minimatch. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
minimatch npm | All versions | 3.1.4 |
minimatch npm | All versions | 3.1.4 |
minimatch npm | From 10.0.0 | 10.2.3 |
minimatch npm | From 10.0.0 | 10.2.3 |
minimatch npm | From 4.0.0 | 4.2.5 |
minimatch npm | From 4.0.0 | 4.2.5 |
10 more packages
minimatch npm | From 5.0.0 | 5.1.8 |
minimatch npm | From 5.0.0 | 5.1.8 |
minimatch npm | From 6.0.0 | 6.2.2 |
minimatch npm | From 6.0.0 | 6.2.2 |
minimatch npm | From 7.0.0 | 7.4.8 |
minimatch npm | From 7.0.0 | 7.4.8 |
minimatch npm | From 8.0.0 | 8.0.6 |
minimatch npm | From 8.0.0 | 8.0.6 |
minimatch npm | From 9.0.0 | 9.0.7 |
minimatch npm | From 9.0.0 | 9.0.7 |
Linux distribution packages (3)
cockpit-repos openSUSE:Tumbleweed | All versions | 4.9-1.1 |
cockpit-subscriptions openSUSE:Tumbleweed | All versions | 16.3-1.1 |
onnxruntime openSUSE:Tumbleweed | All versions | 1.26.0-1.1 |
Products include Minimatch Project Minimatch.
How do I fix CVE-2026-27904?
Upgrade minimatch to a fixed version for your release line: 3.1.4, 10.2.3, 4.2.5 or 5.1.8.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-27904 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-27904 exists.
Other vulnerabilities in isaacs minimatch
Sources
Also known as CLEANSTART-2026-HA54689, CLEANSTART-2026-LT23543, CLEANSTART-2026-RQ08724, CLSA-2026-1791289858, CLSA-2026-1791292466, CLSA-2026-1792254949 and 54 more.