# CVE-2026-27934: Discourse leaks private topic title and post excerpt via user action API endpoint

> Attackers can view private topic titles and excerpts via an API endpoint lacking visibility checks, exposing sensitive data to unauthorized users.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Mar 2026
- **Updated:** 20 Mar 2026
- **Also known as:** BIT-discourse-2026-27934, GHSA-824f-66wh-xx3g

## What is CVE-2026-27934?

CVE-2026-27934 is a high-severity vulnerability in Discourse Discourse, published on 19 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Discourse is an open-source discussion platform. Versions prior to 2026.3.0-latest.1, 2026.2.1, and 2026.1.2 have a lack of visibility checks with a user action API endpoint that results in disclosure of the title and post excerpt to unauthorized users, leading to information disclosure. Versions 2026.3.0-latest.1, 2026.2.1, and 2026.1.2 contain a patch. No known workarounds are available.

Weakness: CWE-201 (Insertion of Sensitive Information Into Sent Data)

## Which versions are affected by CVE-2026-27934?

1 open source package ship an affected version, including discourse. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `discourse` | Bitnami | From 2026.1.0 | 2026.1.2, 2026.2.1, 2026.3.0 |

Products: Discourse Discourse.

## How do I fix CVE-2026-27934?

Upgrade discourse to a fixed version for your release line: 2026.1.2, 2026.2.1 or 2026.3.0.

## Is CVE-2026-27934 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-27934 exists.

Public exploit code:

- Discourse < 2026.1.2/2026.2.1/2026.3.0-latest.1 - Unauthenticated Private User Action Disclosure (nuclei): http/cves/2026/CVE-2026-27934.yaml

## Other vulnerabilities in Discourse Discourse

- [CVE-2021-41163](https://insights.sbomify.com/CVE-2021-41163/): RCE via malicious SNS subscription payload (critical 10.0)
- [CVE-2022-36066](https://insights.sbomify.com/CVE-2022-36066/): Discourse vulnerable to RCE via admins uploading maliciously zipped file (critical 9.1)
- [CVE-2022-39356](https://insights.sbomify.com/CVE-2022-39356/): Discourse user account takeover via email and invite link (high 8.9)
- [CVE-2023-22468](https://insights.sbomify.com/CVE-2023-22468/): Discourse vulnerable to Cross-site Scripting in local oneboxes (high 8.8)
- [CVE-2025-48053](https://insights.sbomify.com/CVE-2025-48053/): Discourse vulnerable to DoS via large URL payload in PM to a bot (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-27934 and fix it if it is affected.

What it is: CVE-2026-27934 is a high-severity vulnerability in Discourse Discourse, published on 19 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-27934 exists.

Affected packages and fixed versions:
- discourse (Bitnami): affected from 2026.1.0; fixed in 2026.1.2, 2026.2.1, 2026.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-27934/ (Markdown: https://insights.sbomify.com/CVE-2026-27934/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-27934
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-27934
- OSV: https://osv.dev/vulnerability/CVE-2026-27934

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-27934/
Summaries are generated and may contain mistakes; the official description above is the record.
