CVE-2026-27935 Discourse leaks private topic metadata to non-authorized users

Medium 6.9 Published Updated

Attackers with moderator privileges can access private topic metadata belonging to admin users, exposing sensitive information.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-27935?

CVE-2026-27935 is a medium-severity vulnerability in Discourse Discourse, published on 19 Mar 2026. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

Discourse is an open-source discussion platform. Versions prior to 2026.3.0-latest.1, 2026.2.1, and 2026.1.2 have a vulnerability in an API endpoint that discloses private topic metadata of admin users to moderator users even if the moderators do not have access to the private topics. Versions 2026.3.0-latest.1, 2026.2.1, and 2026.1.2 contain a patch. No known workarounds are available.

Weakness: CWE-201

Which versions are affected by CVE-2026-27935?

1 open source package ship an affected version, including discourse. It affects 1 product.

PackageAffectedFixed in
discourse BitnamiFrom 2026.1.02026.1.2, 2026.2.1, 2026.4.0

Products include Discourse Discourse.

How do I fix CVE-2026-27935?

Upgrade discourse to a fixed version for your release line: 2026.1.2, 2026.2.1 or 2026.4.0.

Is CVE-2026-27935 being exploited?

There is no known exploitation of CVE-2026-27935 in the wild and no public exploit code.

All Discourse Discourse vulnerabilities

Sources

Also known as BIT-discourse-2026-27935, GHSA-wxqr-r4wv-cw76.

Is CVE-2026-27935 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free