CVE-2026-27936 Discourse discloses restricted post-action counts to non-privileged users

Medium 6.9 Published Updated

Attackers can view restricted post action counts via crafted requests, exposing sensitive data to non-privileged users.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-27936?

CVE-2026-27936 is a medium-severity vulnerability in Discourse Discourse, published on 19 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Discourse is an open-source discussion platform. Prior to versions 2026.3.0-latest.1, 2026.2.1, and 2026.1.2, a restriction bypass allows restricted post action counts to be disclosed to non-privileged users through a carefully crafted request. Versions 2026.3.0-latest.1, 2026.2.1, and 2026.1.2 contain a patch. No known workarounds are available.

Weakness: CWE-863

Which versions are affected by CVE-2026-27936?

1 open source package ship an affected version, including discourse. It affects 1 product.

PackageAffectedFixed in
discourse BitnamiFrom 2026.1.02026.1.2, 2026.2.1, 2026.4.0

Products include Discourse Discourse.

How do I fix CVE-2026-27936?

Upgrade discourse to a fixed version for your release line: 2026.1.2, 2026.2.1 or 2026.4.0.

Is CVE-2026-27936 being exploited?

There is no known exploitation of CVE-2026-27936 in the wild and no public exploit code.

All Discourse Discourse vulnerabilities

Sources

Also known as BIT-discourse-2026-27936, GHSA-v9r3-p863-6f25.

Is CVE-2026-27936 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free