CVE-2026-27937 October: Reflected XSS via DataTable Form Widget
Attackers can execute arbitrary scripts in the October CMS backend via a reflected XSS vulnerability in the DataTable widget.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2026-27937?
CVE-2026-27937 is a low-severity cross-site scripting vulnerability in octobercms october, published on 21 Apr 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
October is a Content Management System (CMS) and web platform. Prior to 3.7.16 and 4.1.16, a reflected Cross-Site Scripting (XSS) vulnerability was identified in the backend DataTable widget where a query parameter was rendered without proper output escaping. This vulnerability is fixed in 3.7.16 and 4.1.16.
Weakness: CWE-79
Which versions are affected by CVE-2026-27937?
4 open source packages ship an affected version, including october/system.
| Package | Affected | Fixed in |
|---|---|---|
october/system Packagist | All versions | 3.7.16 |
october/system Packagist | All versions | 3.7.16 |
october/system Packagist | From 4.0.0 | None |
october/system Packagist | From 4.0.0 | None |
How do I fix CVE-2026-27937?
Upgrade october/system to 3.7.16 or later.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2026-27937 being exploited?
There is no known exploitation of CVE-2026-27937 in the wild and no public exploit code.
Sources
Also known as GHSA-jj38-h5w5-mvpf.