{"answers":{"affected":"4 open source packages ship an affected version, including october/system.","exploited":"There is no known exploitation of CVE-2026-27937 in the wild and no public exploit code.","fix":"Upgrade october/system to 3.7.16 or later.","what":"CVE-2026-27937 is a low-severity cross-site scripting vulnerability in octobercms october, published on 21 Apr 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-27937 and fix it if it is affected.\n\nWhat it is: CVE-2026-27937 is a low-severity cross-site scripting vulnerability in octobercms october, published on 21 Apr 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-27937 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- october/system (Packagist): affected all versions; fixed in 3.7.16\n- october/system (Packagist): affected all versions; fixed in 3.7.16\n- october/system (Packagist): affected from 4.0.0; no fix listed\n- october/system (Packagist): affected from 4.0.0; no fix listed\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-27937/ (Markdown: https://insights.sbomify.com/CVE-2026-27937/index.md)","id":"CVE-2026-27937","markdown":"https://insights.sbomify.com/CVE-2026-27937/index.md","name":"CVE-2026-27937","record":{"aliases":["GHSA-jj38-h5w5-mvpf"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"October CMS","requires_auth":"none","summary":"Attackers can execute arbitrary scripts in the October CMS backend via a reflected XSS vulnerability in the DataTable widget.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":3.1,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"October is a Content Management System (CMS) and web platform. Prior to 3.7.16 and 4.1.16, a reflected Cross-Site Scripting (XSS) vulnerability was identified in the backend DataTable widget where a query parameter was rendered without proper output escaping. This vulnerability is fixed in 3.7.16 and 4.1.16.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"October: Reflected XSS via DataTable Form Widget","id":"CVE-2026-27937","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2026"},"n_packages":4,"n_references":1,"next":{"headline":"WPGraphQL Repo Vulnerable to Command Injection via Unsanitized GitHub Actions Expression in Release Workflow","id":"CVE-2026-27938"},"packages":[{"ecosystem":"Packagist","fixed":["3.7.16"],"introduced":["0"],"last_affected":[],"package":"october/system","purl":null,"source":"GHSA-jj38-h5w5-mvpf"},{"ecosystem":"Packagist","fixed":["3.7.16"],"introduced":["0"],"last_affected":[],"package":"october/system","purl":"pkg:composer/october/system","source":"GHSA-jj38-h5w5-mvpf"},{"ecosystem":"Packagist","fixed":[],"introduced":["4.0.0"],"last_affected":[],"package":"october/system","purl":null,"source":"GHSA-jj38-h5w5-mvpf"},{"ecosystem":"Packagist","fixed":[],"introduced":["4.0.0"],"last_affected":[],"package":"october/system","purl":"pkg:composer/october/system","source":"GHSA-jj38-h5w5-mvpf"}],"prev":{"headline":"Discourse discloses restricted post-action counts to non-privileged users","id":"CVE-2026-27936"},"products":["october"],"published":"2026-04-21","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-04-21","vendors":["octobercms"]},"summary":"Attackers can execute arbitrary scripts in the October CMS backend via a reflected XSS vulnerability in the DataTable widget.","url":"https://insights.sbomify.com/CVE-2026-27937/"}