# CVE-2026-27937: October: Reflected XSS via DataTable Form Widget

> Attackers can execute arbitrary scripts in the October CMS backend via a reflected XSS vulnerability in the DataTable widget.

- **Severity:** Low 3.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 21 Apr 2026
- **Updated:** 21 Apr 2026
- **Also known as:** GHSA-jj38-h5w5-mvpf

## What is CVE-2026-27937?

CVE-2026-27937 is a low-severity cross-site scripting vulnerability in octobercms october, published on 21 Apr 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

October is a Content Management System (CMS) and web platform. Prior to 3.7.16 and 4.1.16, a reflected Cross-Site Scripting (XSS) vulnerability was identified in the backend DataTable widget where a query parameter was rendered without proper output escaping. This vulnerability is fixed in 3.7.16 and 4.1.16.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-27937?

4 open source packages ship an affected version, including october/system.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `october/system` | Packagist | All versions | 3.7.16 |
| `october/system` | Packagist | All versions | 3.7.16 |
| `october/system` | Packagist | From 4.0.0 | None |
| `october/system` | Packagist | From 4.0.0 | None |

## How do I fix CVE-2026-27937?

Upgrade october/system to 3.7.16 or later.

## Is CVE-2026-27937 being exploited?

There is no known exploitation of CVE-2026-27937 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-27937 and fix it if it is affected.

What it is: CVE-2026-27937 is a low-severity cross-site scripting vulnerability in octobercms october, published on 21 Apr 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-27937 in the wild and no public exploit code.

Affected packages and fixed versions:
- october/system (Packagist): affected all versions; fixed in 3.7.16
- october/system (Packagist): affected all versions; fixed in 3.7.16
- october/system (Packagist): affected from 4.0.0; no fix listed
- october/system (Packagist): affected from 4.0.0; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-27937/ (Markdown: https://insights.sbomify.com/CVE-2026-27937/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-27937
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-27937
- OSV: https://osv.dev/vulnerability/CVE-2026-27937

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-27937/
Summaries are generated and may contain mistakes; the official description above is the record.
