CVE-2026-27939 Statamic allows Authenticated Control Panel users to escalate privileges via elevated session bypass

High 8.8 Published Updated

Authenticated users can bypass verification steps to gain elevated privileges and access sensitive operations in Statamic CMS.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-27939?

CVE-2026-27939 is a high-severity vulnerability in statamic cms, published on 27 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Statmatic is a Laravel and Git powered content management system (CMS). Starting in version 6.0.0 and prior to version 6.4.0, Authenticated Control Panel users may under certain conditions obtain elevated privileges without completing the intended verification step. This can allow access to sensitive operations and, depending on the user’s existing permissions, may lead to privilege escalation. This has been fixed in 6.4.0.

Weakness: CWE-287

Which versions are affected by CVE-2026-27939?

2 open source packages ship an affected version, including statamic/cms. It affects 1 product.

PackageAffectedFixed in
statamic/cms PackagistFrom 6.0.06.4.0
statamic/cms PackagistFrom 6.0.06.4.0

Products include Statamic Statamic.

How do I fix CVE-2026-27939?

Upgrade statamic/cms to 6.4.0 or later.

Is CVE-2026-27939 being exploited?

There is no known exploitation of CVE-2026-27939 in the wild and no public exploit code.

Sources

Also known as GHSA-rw9x-pxqx-q789.

Is CVE-2026-27939 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free