{"answers":{"affected":"1 open source package ship an affected version, including openlit. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-27941 exists.","fix":"Upgrade openlit to 1.37.1 or later.","what":"CVE-2026-27941 is a critical code injection vulnerability in openlit, published on 26 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-27941 and fix it if it is affected.\n\nWhat it is: CVE-2026-27941 is a critical code injection vulnerability in openlit, published on 26 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-27941 exists.\n\nAffected packages and fixed versions:\n- openlit (PyPI): affected from 1.36.2; fixed in 1.37.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-27941/ (Markdown: https://insights.sbomify.com/CVE-2026-27941/index.md)","id":"CVE-2026-27941","markdown":"https://insights.sbomify.com/CVE-2026-27941/index.md","name":"CVE-2026-27941","record":{"aliases":["GHSA-9jgv-x8cq-296q","PYSEC-2026-2246"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["code_execution","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"AI engineering platform","requires_auth":"low_privilege","summary":"Attackers can execute arbitrary code and steal secrets by exploiting unsafe GitHub Actions workflows that process untrusted pull request code.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"openlit_software_development_kit","vendor":"openlit"}],"cvss":{"score":10,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-829","name":"Inclusion of Functionality from Untrusted Control Sphere"}],"description":"OpenLIT is an open source platform for AI engineering. Prior to version 1.37.1, several GitHub Actions workflows in OpenLIT's GitHub repository use the `pull_request_target` event while checking out and executing untrusted code from forked pull requests. These workflows run with the security context of the base repository, including a write-privileged `GITHUB_TOKEN` and numerous sensitive secrets (API keys, database/vector store tokens, and a Google Cloud service account key). Version 1.37.1 contains a fix.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":"2026-09-04","github_poc":1,"max_poc_stars":0,"metasploit":0,"nuclei":0,"refs":[{"date":"2026-09-04T19:55:48Z","kind":"github_poc","ref":"https://github.com/pvharmo2/gha-lab-6c3094af9e","stars":0,"title":"Authorized security-research lab reproducing CVE-2026-27941 (pwn request in pull_request_target workflows) — snapshot of openlit/openlit"}],"tier":"weaponised"},"has_fix":true,"headline":"Code injection in openlit","id":"CVE-2026-27941","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"code_injection","year":"2026"},"n_packages":1,"n_references":2,"next":{"headline":"fast-xml-parser has stack overflow in XMLBuilder with preserveOrder","id":"CVE-2026-27942"},"packages":[{"ecosystem":"PyPI","fixed":["1.37.1"],"introduced":["1.36.2"],"last_affected":[],"package":"openlit","purl":"pkg:pypi/openlit","source":"PYSEC-2026-2246"}],"prev":{"headline":"llama.cpp has a Heap Buffer Overflow via Integer Overflow in `mem_size` Calculation — Bypass of CVE-2025-53630 Fix","id":"CVE-2026-27940"},"products":["openlit"],"published":"2026-02-26","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-02-26","vendors":["openlit"]},"summary":"Attackers can execute arbitrary code and steal secrets by exploiting unsafe GitHub Actions workflows that process untrusted pull request code.","url":"https://insights.sbomify.com/CVE-2026-27941/"}