# CVE-2026-27941: Code injection in openlit

> Attackers can execute arbitrary code and steal secrets by exploiting unsafe GitHub Actions workflows that process untrusted pull request code.

- **Severity:** Critical 10.0 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Feb 2026
- **Updated:** 26 Feb 2026
- **Also known as:** GHSA-9jgv-x8cq-296q, PYSEC-2026-2246

## What is CVE-2026-27941?

CVE-2026-27941 is a critical code injection vulnerability in openlit, published on 26 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

OpenLIT is an open source platform for AI engineering. Prior to version 1.37.1, several GitHub Actions workflows in OpenLIT's GitHub repository use the `pull_request_target` event while checking out and executing untrusted code from forked pull requests. These workflows run with the security context of the base repository, including a write-privileged `GITHUB_TOKEN` and numerous sensitive secrets (API keys, database/vector store tokens, and a Google Cloud service account key). Version 1.37.1 contains a fix.

Weakness: CWE-829 (Inclusion of Functionality from Untrusted Control Sphere)

## Which versions are affected by CVE-2026-27941?

1 open source package ship an affected version, including openlit. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `openlit` | PyPI | From 1.36.2 | 1.37.1 |

Products: Openlit Openlit Software Development Kit.

## How do I fix CVE-2026-27941?

Upgrade openlit to 1.37.1 or later.

## Is CVE-2026-27941 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-27941 exists.

Public exploit code:

- Authorized security-research lab reproducing CVE-2026-27941 (pwn request in pull_request_target workflows) — snapshot of openlit/openlit (github_poc): https://github.com/pvharmo2/gha-lab-6c3094af9e

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-27941 and fix it if it is affected.

What it is: CVE-2026-27941 is a critical code injection vulnerability in openlit, published on 26 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-27941 exists.

Affected packages and fixed versions:
- openlit (PyPI): affected from 1.36.2; fixed in 1.37.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-27941/ (Markdown: https://insights.sbomify.com/CVE-2026-27941/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-27941
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-27941
- OSV: https://osv.dev/vulnerability/CVE-2026-27941

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-27941/
Summaries are generated and may contain mistakes; the official description above is the record.
