# CVE-2026-27942: fast-xml-parser has stack overflow in XMLBuilder with preserveOrder

> An attacker can cause a stack overflow crash in fast-xml-parser by using the XML builder with preserveOrder enabled, leading to denial of service.

- **Severity:** Low 2.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:U`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Feb 2026
- **Updated:** 23 Jun 2026
- **Also known as:** CLEANSTART-2026-DD01525, CLEANSTART-2026-ZT14752, CLSA-2026-1789289706, DEBIAN-CVE-2026-27942, ECHO-a140-4efb-7c2a, GHSA-fj3w-jwp8-x2g3, MINI-3jx3-mqx7-99pm, MINI-44qw-grm7-q322, MINI-59p8-fjv4-pr8g, MINI-99c3-c23w-cgx8, MINI-cf2r-m833-4r76, MINI-cmqj-g259-pf97, MINI-cx7c-xh4j-mf56, MINI-fx5h-8735-hhg5, MINI-j5r7-w9x8-9w4c, MINI-mxwx-jm76-j46x, MINI-qf92-hc7x-fvjh, MINI-r833-m6hq-gcw5, MINI-v36x-x8gx-26j3, MINI-v763-v69w-jvrm, MINI-wvgj-5ffg-8cj2, ROOT-APP-NPM-CVE-2026-27942, UBUNTU-CVE-2026-27942

## What is CVE-2026-27942?

CVE-2026-27942 is a low-severity denial of service vulnerability in NaturalIntelligence fast-xml-parser, published on 26 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

fast-xml-parser allows users to validate XML, parse XML to JS object, or build XML from JS object without C/C++ based libraries and no callback. Prior to version 5.3.8, the application crashes with stack overflow when user use XML builder with `preserveOrder:true`. Version 5.3.8 fixes the issue. As a workaround, use XML builder with `preserveOrder:false` or check the input data before passing to builder.

Weakness: CWE-120 (Buffer Copy without Checking Size of Input)

## Which versions are affected by CVE-2026-27942?

4 open source packages ship an affected version, including fast-xml-parser. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `fast-xml-parser` | npm | From 4.0.0-beta.0 | 4.5.4 |
| `fast-xml-parser` | npm | From 4.0.0-beta.0 | 4.5.4 |
| `fast-xml-parser` | npm | From 5.0.0 | 5.3.8 |
| `fast-xml-parser` | npm | From 5.0.0 | 5.3.8 |

Products: Naturalintelligence Fast-Xml-Parser.

## How do I fix CVE-2026-27942?

Upgrade fast-xml-parser to a fixed version for your release line: 4.5.4 or 5.3.8.

## Is CVE-2026-27942 being exploited?

There is no known exploitation of CVE-2026-27942 in the wild and no public exploit code.

## Other vulnerabilities in NaturalIntelligence fast-xml-parser

- [CVE-2026-25896](https://insights.sbomify.com/CVE-2026-25896/): fast-xml-parser has an entity encoding bypass via regex injection in DOCTYPE entity names (critical 9.3)
- [CVE-2026-33036](https://insights.sbomify.com/CVE-2026-33036/): fast-xml-parser affected by numeric entity expansion bypassing all entity expansion limits (incomplete fix for CVE-2026-26278) (high 7.5)
- [CVE-2026-26278](https://insights.sbomify.com/CVE-2026-26278/): fast-xml-parser affected by DoS through entity expansion in DOCTYPE (no expansion limit) (high 7.5)
- [CVE-2026-25128](https://insights.sbomify.com/CVE-2026-25128/): fast-xml-parser has RangeError DoS Numeric Entities Bug (high 7.5)
- [CVE-2024-41818](https://insights.sbomify.com/CVE-2024-41818/): ReDOS at currency parsing fast-xml-parser (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-27942 and fix it if it is affected.

What it is: CVE-2026-27942 is a low-severity denial of service vulnerability in NaturalIntelligence fast-xml-parser, published on 26 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-27942 in the wild and no public exploit code.

Affected packages and fixed versions:
- fast-xml-parser (npm): affected from 4.0.0-beta.0; fixed in 4.5.4
- fast-xml-parser (npm): affected from 4.0.0-beta.0; fixed in 4.5.4
- fast-xml-parser (npm): affected from 5.0.0; fixed in 5.3.8
- fast-xml-parser (npm): affected from 5.0.0; fixed in 5.3.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-27942/ (Markdown: https://insights.sbomify.com/CVE-2026-27942/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-27942
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-27942
- OSV: https://osv.dev/vulnerability/CVE-2026-27942

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-27942/
Summaries are generated and may contain mistakes; the official description above is the record.
