# CVE-2026-27944: Nginx UI: Unauthenticated Backup Download with Encryption Key Disclosure

> Unauthenticated attackers can download and decrypt Nginx UI backups, exposing sensitive credentials and keys.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Mar 2026
- **Updated:** 19 Mar 2026
- **Also known as:** GHSA-g9w5-qffc-6762, GO-2026-4614

## What is CVE-2026-27944?

CVE-2026-27944 is a critical missing authorization vulnerability in 0xJacky nginx-ui, published on 5 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Nginx UI is a web user interface for the Nginx web server. Prior to version 2.3.3, the /api/backup endpoint is accessible without authentication and discloses the encryption keys required to decrypt the backup in the X-Backup-Security response header. This allows an unauthenticated attacker to download a full system backup containing sensitive data (user credentials, session tokens, SSL private keys, Nginx configurations) and decrypt it immediately. This issue has been patched in version 2.3.3.

Weakness: CWE-311 (Missing Encryption of Sensitive Data), CWE-306 (Missing Authentication for Critical Functionality)

## Which versions are affected by CVE-2026-27944?

3 open source packages ship an affected version, including github.com/0xJacky/Nginx-UI. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/0xJacky/Nginx-UI` | Go | All versions | None |
| `github.com/0xJacky/Nginx-UI` | Go | All versions | 2.3.3 |
| `github.com/0xJacky/Nginx-UI` | Go | All versions | 2.3.3 |

Products: Nginxui Nginx Ui.

## How do I fix CVE-2026-27944?

Upgrade github.com/0xJacky/Nginx-UI to 2.3.3 or later.

## Is CVE-2026-27944 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-27944 exists.

Public exploit code:

- Automated exploit script for CVE-2026-27944 (Nginx UI). Downloads/decrypts backups, extracts system secrets, and creates rogue admin accounts for full dashboard access. (github_poc): https://github.com/Skynoxk/CVE-2026-27944
- CVE-2026-27944 - Nginx UI Unauthenticated Backup Download & Decryption (github_poc): https://github.com/NULL200OK/CVE-2026-27944
- Nginx UI Discovery Scanner - CVE-2026-27944 Version Detector (github_poc): https://github.com/NULL200OK/-nginxui_discover
- An educational deep-dive into CVE-2026-27944 (github_poc): https://github.com/jake-young-dev/CVE-2026-27944
- HTB Snapped — Hard Linux machine writeup. CVE-2026-27944 (Nginx UI unauthenticated backup disclosure) chained with CVE-2026-3888 (snapd race condition LPE) to achieve full system compromise. (github_poc): https://github.com/karimelsheikh1/HTB-Snapped-Writeup
- Suka suka lah (github_poc): https://github.com/BimaBalance/Cve-2026-27944-Tools-Exploit

## Other vulnerabilities in 0xJacky nginx-ui

- [CVE-2026-33032](https://insights.sbomify.com/CVE-2026-33032/): Nginx UI: Unauthenticated MCP Endpoint Allows Remote Nginx Takeover (critical 9.8)
- [CVE-2024-23827](https://insights.sbomify.com/CVE-2024-23827/): Nginx-UI arbitrary file write through the Import Certificate feature (critical 9.8)
- [CVE-2026-107806](https://insights.sbomify.com/CVE-2026-107806/): Nginx UI: Authenticated Remote Code Execution via Backup Restore App Config Overwrite (critical 9.4)
- [CVE-2026-33026](https://insights.sbomify.com/CVE-2026-33026/): nginx-ui Backup Restore Allows Tampering with Encrypted Backups (critical 9.4)
- [CVE-2026-42238](https://insights.sbomify.com/CVE-2026-42238/): Unauthenticated Remote Code Execution via Backup Restore in nginx-ui (critical 9.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-27944 and fix it if it is affected.

What it is: CVE-2026-27944 is a critical missing authorization vulnerability in 0xJacky nginx-ui, published on 5 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-27944 exists.

Affected packages and fixed versions:
- github.com/0xJacky/Nginx-UI (Go): affected all versions; no fix listed
- github.com/0xJacky/Nginx-UI (Go): affected all versions; fixed in 2.3.3
- github.com/0xJacky/Nginx-UI (Go): affected all versions; fixed in 2.3.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-27944/ (Markdown: https://insights.sbomify.com/CVE-2026-27944/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-27944
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-27944
- OSV: https://osv.dev/vulnerability/CVE-2026-27944

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-27944/
Summaries are generated and may contain mistakes; the official description above is the record.
