# CVE-2026-27946: ZITADEL Users Can Self-Verify Email/Phone via UpdateHumanUser API

> Attackers can bypass email and phone verification checks in ZITADEL by self-verifying their contact details via the API.

- **Severity:** High 8.2 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:H/VA:N/SC:N/SI:H/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 26 Feb 2026
- **Updated:** 26 Feb 2026
- **Also known as:** GHSA-282g-fhmx-xf54, GO-2026-4572

## What is CVE-2026-27946?

CVE-2026-27946 is a high-severity missing authorization vulnerability in zitadel, published on 26 Feb 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

ZITADEL is an open source identity management platform. Prior to versions 4.11.1 and 3.4.7, a vulnerability in Zitadel's self-management capability allowed users to mark their email and phone as verified without going through an actual verification process. The patch in versions 4.11.1 and 3.4.7 resolves the issue by requiring the correct permission in case the verification flag is provided and only allows self-management of the email address and/or phone number itself. If an upgrade is not possible, an action (v2) could be used to prevent setting the verification flag on the own user.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-27946?

7 open source packages ship an affected version, including github.com/zitadel/zitadel. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/zitadel/zitadel` | Go | All versions | 1.80.0-v2.20.0.20260225053417-0261536243e5 |
| `github.com/zitadel/zitadel` | Go | All versions | 1.80.0-v2.20.0.20260225053417-0261536243e5 |
| `github.com/zitadel/zitadel` | Go | All versions | 1.80.0-v2.20.0.20260225053417-0261536243e5 |
| `github.com/zitadel/zitadel` | Go | From 2.43.0 | 3.4.7 |
| `github.com/zitadel/zitadel` | Go | From 2.43.0 | 3.4.7 |
| `github.com/zitadel/zitadel` | Go | From 4.0.0 | 4.11.1 |
| `github.com/zitadel/zitadel` | Go | From 4.0.0 | 4.11.1 |

Products: Zitadel Zitadel.

## How do I fix CVE-2026-27946?

Upgrade github.com/zitadel/zitadel to a fixed version for your release line: 1.80.0-v2.20.0.20260225053417-0261536243e5, 3.4.7 or 4.11.1.

## Is CVE-2026-27946 being exploited?

There is no known exploitation of CVE-2026-27946 in the wild and no public exploit code.

## Other vulnerabilities in zitadel

- [CVE-2026-29191](https://insights.sbomify.com/CVE-2026-29191/): ZITADEL: 1-Click Account Takeover via XSS in /saml-post Endpoint (critical 9.3)
- [CVE-2025-67494](https://insights.sbomify.com/CVE-2025-67494/): ZITADEL Vulnerable to Unauthenticated Full-Read SSRF via V2 Login (critical 9.3)
- [CVE-2025-27507](https://insights.sbomify.com/CVE-2025-27507/): IDOR Vulnerabilities in ZITADEL's Admin API that Primarily Impact LDAP Configurations (critical 9.0)
- [CVE-2025-64103](https://insights.sbomify.com/CVE-2025-64103/): Zitadel Bypass Second Authentication Factor (high 8.7)
- [CVE-2025-31123](https://insights.sbomify.com/CVE-2025-31123/): Zitadel Expired JWT Keys Usable for Authorization Grants (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-27946 and fix it if it is affected.

What it is: CVE-2026-27946 is a high-severity missing authorization vulnerability in zitadel, published on 26 Feb 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-27946 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/zitadel/zitadel (Go): affected all versions; fixed in 1.80.0-v2.20.0.20260225053417-0261536243e5
- github.com/zitadel/zitadel (Go): affected all versions; fixed in 1.80.0-v2.20.0.20260225053417-0261536243e5
- github.com/zitadel/zitadel (Go): affected all versions; fixed in 1.80.0-v2.20.0.20260225053417-0261536243e5
- github.com/zitadel/zitadel (Go): affected from 2.43.0; fixed in 3.4.7
- github.com/zitadel/zitadel (Go): affected from 2.43.0; fixed in 3.4.7
- github.com/zitadel/zitadel (Go): affected from 4.0.0; fixed in 4.11.1
- github.com/zitadel/zitadel (Go): affected from 4.0.0; fixed in 4.11.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-27946/ (Markdown: https://insights.sbomify.com/CVE-2026-27946/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-27946
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-27946
- OSV: https://osv.dev/vulnerability/CVE-2026-27946

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-27946/
Summaries are generated and may contain mistakes; the official description above is the record.
