# CVE-2026-27948: Copyparty vulnerable to eflected cross-site scripting via setck parameter

> Reflected cross-site scripting in Copyparty allows attackers to execute arbitrary scripts via the setck URL parameter.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 26 Feb 2026
- **Updated:** 26 Feb 2026
- **Also known as:** GHSA-62cr-6wp5-q43h, PYSEC-2026-2136

## What is CVE-2026-27948?

CVE-2026-27948 is a medium-severity cross-site scripting vulnerability in 9001 copyparty, published on 26 Feb 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Copyparty is a portable file server. In versions prior to 1.20.9, an XSS allows for reflected cross-site scripting via URL-parameter `?setck=...`. Version 1.20.9 fixes the issue.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-27948?

3 open source packages ship an affected version, including copyparty. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `copyparty` | PyPI | All versions | 1.20.9 |
| `copyparty` | PyPI | All versions | 1.20.9 |
| `copyparty` | PyPI | All versions | 1.20.9 |

Products: 9001 Copyparty.

## How do I fix CVE-2026-27948?

Upgrade copyparty to 1.20.9 or later.

## Is CVE-2026-27948 being exploited?

There is no known exploitation of CVE-2026-27948 in the wild and no public exploit code.

## Other vulnerabilities in 9001 copyparty

- [CVE-2023-41471](https://insights.sbomify.com/CVE-2023-41471/): Cross-site scripting in n/a (high 7.8)
- [CVE-2025-54796](https://insights.sbomify.com/CVE-2025-54796/): Copyparty is vulnerable to Regex Denial of Service (ReDoS) attacks through "Recent Uploads" page (high 7.5)
- [CVE-2023-37474](https://insights.sbomify.com/CVE-2023-37474/): Path traversal in copyparty (high 7.5)
- [CVE-2025-54589](https://insights.sbomify.com/CVE-2025-54589/): copyparty Reflected XSS via Filter Parameter (medium 6.3)
- [CVE-2023-38501](https://insights.sbomify.com/CVE-2023-38501/): copyparty vulnerable to reflected cross-site scripting via k304 parameter (medium 6.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-27948 and fix it if it is affected.

What it is: CVE-2026-27948 is a medium-severity cross-site scripting vulnerability in 9001 copyparty, published on 26 Feb 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-27948 in the wild and no public exploit code.

Affected packages and fixed versions:
- copyparty (PyPI): affected all versions; fixed in 1.20.9
- copyparty (PyPI): affected all versions; fixed in 1.20.9
- copyparty (PyPI): affected all versions; fixed in 1.20.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-27948/ (Markdown: https://insights.sbomify.com/CVE-2026-27948/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-27948
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-27948
- OSV: https://osv.dev/vulnerability/CVE-2026-27948

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-27948/
Summaries are generated and may contain mistakes; the official description above is the record.
