CVE-2026-27960 OpenCTI privilege escalation and unauthenticated access via default admin account

Critical 9.8 Published Updated

Unauthenticated attackers can escalate privileges and access the API as any user, including the default admin, in OpenCTI.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-27960?

CVE-2026-27960 is a critical authentication bypass vulnerability in OpenCTI-Platform opencti, published on 5 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

OpenCTI is an open source platform for managing cyber threat intelligence knowledge and observables. In versions 6.6.0 through 6.9.12, there is a privilege escalation vulnerability that can be exploited by unauthenticated attackers to query the API as any existing user, including the default admin account. This issue has been fixed in version 6.9.13. As a workaround, the default admin can be disabled using the `APP__ADMIN__EXTERNALLY_MANAGED` configuration.

Weakness: CWE-287

Which versions are affected by CVE-2026-27960?

1 open source package ship an affected version, including pycti. It affects 1 product.

PackageAffectedFixed in
pycti PyPIFrom 6.9.06.9.13

Products include Citeum Opencti.

How do I fix CVE-2026-27960?

Upgrade pycti to 6.9.13 or later.

Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.

Is CVE-2026-27960 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-27960 exists.

Public exploit code: 1 Metasploit module and 1 Nuclei template.

Sources

Also known as GHSA-6vvv-vmfr-xhrx, PYSEC-2026-119.

Is CVE-2026-27960 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free