# CVE-2026-27962: Authlib JWS JWK Header Injection: Signature Verification Bypass

> Attackers can forge JWT tokens to bypass authentication and authorization in applications using the Authlib Python library.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Mar 2026
- **Updated:** 10 Sep 2026
- **Also known as:** DEBIAN-CVE-2026-27962, ECHO-e780-297e-3c37, GHSA-wvwj-cvrp-7pv5, MINI-59xw-6ffh-rr9c, MINI-hcvv-cw5v-gmjm, PYSEC-2026-287, ROOT-APP-PYPI-CVE-2026-27962, UBUNTU-CVE-2026-27962

## What is CVE-2026-27962?

CVE-2026-27962 is a critical authentication bypass vulnerability in authlib, published on 16 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Authlib is a Python library which builds OAuth and OpenID Connect servers. Prior to version 1.6.9, a JWK Header Injection vulnerability in authlib's JWS implementation allows an unauthenticated attacker to forge arbitrary JWT tokens that pass signature verification. When key=None is passed to any JWS deserialization function, the library extracts and uses the cryptographic key embedded in the attacker-controlled JWT jwk header field. An attacker can sign a token with their own private key, embed the matching public key in the header, and have the server accept the forged token as cryptographically valid — bypassing authentication and authorization entirely. This issue has been patched in version 1.6.9.

Weakness: CWE-347 (Improper Verification of Cryptographic Signature)

## Which versions are affected by CVE-2026-27962?

3 open source packages ship an affected version, including authlib. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `authlib` | PyPI | All versions | 1.6.9 |
| `authlib` | PyPI | All versions | 1.6.9 |
| `authlib` | PyPI | All versions | 1.6.9 |

Products: Authlib Authlib.

## How do I fix CVE-2026-27962?

Upgrade authlib to 1.6.9 or later.

## Is CVE-2026-27962 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-27962 exists.

## Other vulnerabilities in authlib

- [CVE-2026-28490](https://insights.sbomify.com/CVE-2026-28490/): Authlib Vulnerable to JWE RSA1_5 Bleichenbacher Padding Oracle (high 8.3)
- [CVE-2026-28498](https://insights.sbomify.com/CVE-2026-28498/): Authlib: Fail-Open Cryptographic Verification in OIDC Hash Binding (high 8.2)
- [CVE-2026-28802](https://insights.sbomify.com/CVE-2026-28802/): Authlib: Setting `alg: none` and a blank signature appears to bypass signature verification (high 7.7)
- [CVE-2025-61920](https://insights.sbomify.com/CVE-2025-61920/): Authlib is vulnerable to Denial of Service via Oversized JOSE Segments (high 7.5)
- [CVE-2025-59420](https://insights.sbomify.com/CVE-2025-59420/): Authlib: JWS/JWT accepts unknown crit headers (RFC violation → possible authz bypass) (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-27962 and fix it if it is affected.

What it is: CVE-2026-27962 is a critical authentication bypass vulnerability in authlib, published on 16 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-27962 exists.

Affected packages and fixed versions:
- authlib (PyPI): affected all versions; fixed in 1.6.9
- authlib (PyPI): affected all versions; fixed in 1.6.9
- authlib (PyPI): affected all versions; fixed in 1.6.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-27962/ (Markdown: https://insights.sbomify.com/CVE-2026-27962/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-27962
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-27962
- OSV: https://osv.dev/vulnerability/CVE-2026-27962

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-27962/
Summaries are generated and may contain mistakes; the official description above is the record.
