CVE-2026-27965 Vitess users with backup storage access can gain unauthorized access to production deployment environments

High 8.4 Published Updated

Attackers with backup storage access can inject commands into manifest files to execute arbitrary code and gain unauthorized access to production environments.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2026-27965?

CVE-2026-27965 is a high-severity command injection vulnerability in vitessio vitess, published on 26 Feb 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

Official description

Vitess is a database clustering system for horizontal scaling of MySQL. Prior to versions 23.0.3 and 22.0.4, anyone with read/write access to the backup storage location (e.g. an S3 bucket) can manipulate backup manifest files so that arbitrary code is later executed when that backup is restored. This can be used to provide that attacker with unintended/unauthorized access to the production deployment environment — allowing them to access information available in that environment as well as run any additional arbitrary commands there. Versions 23.0.3 and 22.0.4 contain a patch. Some workarounds are available. Those who intended to use an external decompressor then can always specify that decompressor command in the `--external-decompressor` flag value for `vttablet` and `vtbackup`. That then overrides any value specified in the manifest file. Those who did not intend to use an external decompressor, nor an internal one, can specify a value such as `cat` or `tee` in the `--external-decompressor` flag value for `vttablet` and `vtbackup` to ensure that a harmless command is always used.

Weakness: CWE-78

Which versions are affected by CVE-2026-27965?

3 open source packages ship an affected version, including vitess.io/vitess. It affects 1 product.

PackageAffectedFixed in
vitess.io/vitess GoAll versions0.22.4, 0.23.3
vitess.io/vitess GoAll versions to 0.23.2None
vitess.io/vitess GoAll versions to 0.23.2None

Products include Linuxfoundation Vitess.

How do I fix CVE-2026-27965?

Upgrade vitess.io/vitess to a fixed version for your release line: 0.22.4 or 0.23.3.

Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.

Is CVE-2026-27965 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-27965 exists.

Sources

Also known as AZL-78356, AZL-78593, GHSA-8g8j-r87h-p36x, GO-2026-4567.

Is CVE-2026-27965 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free