CVE-2026-27970 Angular i18n vulnerable to Cross-Site Scripting (XSS)

High 7.6 Published Updated

Attackers can execute arbitrary JavaScript in Angular applications by compromising translation files containing malicious ICU messages, leading to credential theft or page vandalism.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2026-27970?

CVE-2026-27970 is a high-severity cross-site scripting vulnerability in angular, published on 26 Feb 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

Angular is a development platform for building mobile and desktop web applications using TypeScript/JavaScript and other languages. Versions prior to 21.2.0, 21.1.16, 20.3.17, and 19.2.19 have a cross-Site scripting vulnerability in the Angular internationalization (i18n) pipeline. In ICU messages (International Components for Unicode), HTML from translated content was not properly sanitized and could execute arbitrary JavaScript. Angular i18n typically involves three steps, extracting all messages from an application in the source language, sending the messages to be translated, and then merging their translations back into the final source code. Translations are frequently handled by contracts with specific partner companies, and involve sending the source messages to a separate contractor before receiving final translations for display to the end user. If the returned translations have malicious content, it could be rendered into the application and execute arbitrary JavaScript. When successfully exploited, this vulnerability allows for execution of attacker controlled JavaScript in the application origin. Depending on the nature of the application being exploited this could lead to credential exfiltration and/or page vandalism. Several preconditions apply to the attack. The attacker must compromise the translation file (xliff, xtb, etc.). Unlike most XSS vulnerabilities, this issue is not exploitable by arbitrary users. An attacker must first compromise an application's translation file before they can escalate privileges into the Angular application client. The victim application must use Angular i18n, use one or more ICU messages, render an ICU message, and not defend against XSS via a safe content security policy. Versions 21.2.0, 21.1.6, 20.3.17, and 19.2.19 patch the issue. Until the patch is applied, developers should consider reviewing and verifying translated content received from untrusted third parties before incorporating it in an Angular application, enabling strict CSP controls to block unauthorized JavaScript from executing on the page, and enabling Trusted Types to enforce proper HTML sanitization.

Weakness: CWE-79

Which versions are affected by CVE-2026-27970?

10 open source packages ship an affected version, including @angular/core. It affects 1 product.

PackageAffectedFixed in
@angular/core npmAll versions to 18.2.14None
@angular/core npmAll versions to 18.2.14None
@angular/core npmFrom 19.0.0-next.019.2.19
@angular/core npmFrom 19.0.0-next.019.2.19
@angular/core npmFrom 20.0.0-next.020.3.17
@angular/core npmFrom 20.0.0-next.020.3.17
4 more packages
@angular/core npmFrom 21.0.0-next.021.1.6
@angular/core npmFrom 21.0.0-next.021.1.6
@angular/core npmFrom 21.2.0-next.021.2.0
@angular/core npmFrom 21.2.0-next.021.2.0

Products include Angular Angular.

How do I fix CVE-2026-27970?

Upgrade @angular/core to a fixed version for your release line: 19.2.19, 20.3.17, 21.1.6 or 21.2.0.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2026-27970 being exploited?

There is no known exploitation of CVE-2026-27970 in the wild and no public exploit code.

Sources

Also known as CLSA-2026-1775176191, CLSA-2026-1775176192, CLSA-2026-1775781181, CLSA-2026-1776040411, CLSA-2026-1776040414, CLSA-2026-1776040417 and 188 more.

Is CVE-2026-27970 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free