# CVE-2026-27971: Qwik affected by unauthenticated RCE via server$ Deserialization

> Unauthenticated attackers can execute arbitrary code on servers using the Qwik framework via unsafe deserialization in the server$ RPC mechanism.

- **Severity:** Critical 9.2 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Mar 2026
- **Updated:** 4 Mar 2026
- **Also known as:** GHSA-p9x5-jp3h-96mm

## What is CVE-2026-27971?

CVE-2026-27971 is a critical unsafe deserialization vulnerability in QwikDev qwik, published on 3 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Qwik is a performance focused javascript framework. qwik <=1.19.0 is vulnerable to RCE due to an unsafe deserialization vulnerability in the server$ RPC mechanism that allows any unauthenticated user to execute arbitrary code on the server with a single HTTP request. Affects any deployment where require() is available at runtime. This vulnerability is fixed in 1.19.1.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2026-27971?

2 open source packages ship an affected version, including @builder.io/qwik. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@builder.io/qwik` | npm | All versions | 1.19.1 |
| `@builder.io/qwik` | npm | All versions | 1.19.1 |

Products: Qwik Qwik.

## How do I fix CVE-2026-27971?

Upgrade @builder.io/qwik to 1.19.1 or later.

## Is CVE-2026-27971 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-27971 exists.

Public exploit code:

- CVE-2026-27971 qwik rce (github_poc): https://github.com/Ghalendar/CVE-2026-27971_POC
- Qwik - Unauthenticated RCE via server$ Deserialization (nuclei): http/cves/2026/CVE-2026-27971.yaml

## Other vulnerabilities in QwikDev qwik

- [CVE-2023-1283](https://insights.sbomify.com/CVE-2023-1283/): Code Injection in builderio/qwik (critical 10.0)
- [CVE-2026-25150](https://insights.sbomify.com/CVE-2026-25150/): Prototype Pollution via FormData Processing in Qwik City (critical 9.3)
- [CVE-2026-32701](https://insights.sbomify.com/CVE-2026-32701/): Qwik has array method pollution in FormData processing, allowing type confusion and DoS (high 7.5)
- [CVE-2024-41677](https://insights.sbomify.com/CVE-2024-41677/): Cross-site Scripting (XSS) vulnerability due to improper HTML escaping in qwik (medium 6.3)
- [CVE-2023-0410](https://insights.sbomify.com/CVE-2023-0410/): Cross-site Scripting (XSS) - Generic in builderio/qwik (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-27971 and fix it if it is affected.

What it is: CVE-2026-27971 is a critical unsafe deserialization vulnerability in QwikDev qwik, published on 3 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-27971 exists.

Affected packages and fixed versions:
- @builder.io/qwik (npm): affected all versions; fixed in 1.19.1
- @builder.io/qwik (npm): affected all versions; fixed in 1.19.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-27971/ (Markdown: https://insights.sbomify.com/CVE-2026-27971/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-27971
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-27971
- OSV: https://osv.dev/vulnerability/CVE-2026-27971

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-27971/
Summaries are generated and may contain mistakes; the official description above is the record.
