# CVE-2026-27975: Ajenti has a potential Remote Code Execution


- **Severity:** High 8.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 26 Feb 2026
- **Updated:** 27 Feb 2026
- **Also known as:** GHSA-vcw3-r3fx-j444

## What is CVE-2026-27975?

CVE-2026-27975 is a high-severity vulnerability in ajenti, published on 26 Feb 2026. 

### Official description

Ajenti is a Linux and BSD modular server admin panel. Prior to version 2.2.13, an unauthenticated user could gain access to a server to execute arbitrary code on this server. This is fixed in the version 2.2.13.

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2026-27975?

2 open source packages ship an affected version, including aj. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `aj` | PyPI | All versions | 2.2.13 |
| `aj` | PyPI | All versions | 2.2.13 |

Products: Ajenti Ajenti.

## How do I fix CVE-2026-27975?

Upgrade aj to 2.2.13 or later.

## Is CVE-2026-27975 being exploited?

There is no known exploitation of CVE-2026-27975 in the wild and no public exploit code.

## Other vulnerabilities in ajenti

- [CVE-2018-1000082](https://insights.sbomify.com/CVE-2018-1000082/): Cross-site request forgery in n/a (high 8.8)
- [CVE-2018-1000081](https://insights.sbomify.com/CVE-2018-1000081/): Denial of service in n/a (high 7.5)
- [CVE-2018-1000126](https://insights.sbomify.com/CVE-2018-1000126/): Information disclosure in n/a (high 7.5)
- [CVE-2026-35175](https://insights.sbomify.com/CVE-2026-35175/): Ajenti has an authorization bypass during custom package installation (high 7.2)
- [CVE-2018-1000080](https://insights.sbomify.com/CVE-2018-1000080/): Missing authorization in n/a (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-27975 and fix it if it is affected.

What it is: CVE-2026-27975 is a high-severity vulnerability in ajenti, published on 26 Feb 2026. 
Exploitation: There is no known exploitation of CVE-2026-27975 in the wild and no public exploit code.

Affected packages and fixed versions:
- aj (PyPI): affected all versions; fixed in 2.2.13
- aj (PyPI): affected all versions; fixed in 2.2.13

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-27975/ (Markdown: https://insights.sbomify.com/CVE-2026-27975/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-27975
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-27975
- OSV: https://osv.dev/vulnerability/CVE-2026-27975

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-27975/
Summaries are generated and may contain mistakes; the official description above is the record.
