# CVE-2026-27978: Next.js: null origin can bypass Server Actions CSRF checks

> Attackers can bypass Server Action CSRF checks using null origins from sandboxed iframes, allowing state-changing actions with victim credentials.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 17 Mar 2026
- **Updated:** 18 Mar 2026
- **Also known as:** GHSA-mq59-m269-xvcx, MINI-c5hg-9ww7-fp9h, MINI-hrwq-7pv7-87hw, ROOT-APP-NPM-CVE-2026-27978

## What is CVE-2026-27978?

CVE-2026-27978 is a medium-severity vulnerability in Vercel Next.js, published on 17 Mar 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Next.js is a React framework for building full-stack web applications. Starting in version 16.0.1 and prior to version 16.1.7, `origin: null` was treated as a "missing" origin during Server Action CSRF validation. As a result, requests from opaque contexts (such as sandboxed iframes) could bypass origin verification instead of being validated as cross-origin requests. An attacker could induce a victim browser to submit Server Actions from a sandboxed context, potentially executing state-changing actions with victim credentials (CSRF). This is fixed in version 16.1.7 by treating `'null'` as an explicit origin value and enforcing host/origin checks unless `'null'` is explicitly allowlisted in `experimental.serverActions.allowedOrigins`. If upgrading is not immediately possible, add CSRF tokens for sensitive Server Actions, prefer `SameSite=Strict` on sensitive auth cookies, and/or do not allow `'null'` in `serverActions.allowedOrigins` unless intentionally required and additionally protected.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2026-27978?

2 open source packages ship an affected version, including next. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `next` | npm | From 16.0.1 | 16.1.7 |
| `next` | npm | From 16.0.1 | 16.1.7 |

Products: Vercel Next.js.

## How do I fix CVE-2026-27978?

Upgrade next to 16.1.7 or later.

## Is CVE-2026-27978 being exploited?

There is no known exploitation of CVE-2026-27978 in the wild and no public exploit code.

Public exploit code:

- Some Proof-of-Concept (POCs) for CVE-2025-29927, CVE-2026-27978, and CVE-2026-29057 in Next.js. (github_poc): https://github.com/Nayekah/Next.js-Proof-of-Concept

## Other vulnerabilities in Vercel Next.js

- [CVE-2025-29927](https://insights.sbomify.com/CVE-2025-29927/): Authorization Bypass in Next.js Middleware (critical 9.1)
- [CVE-2026-44578](https://insights.sbomify.com/CVE-2026-44578/): Next.js: Server-side request forgery in applications using WebSocket upgrades (high 8.6)
- [CVE-2026-94483](https://insights.sbomify.com/CVE-2026-94483/): Next.js: Server-Side Request Forgery in Image Optimization (high 8.3)
- [CVE-2026-64642](https://insights.sbomify.com/CVE-2026-64642/): Next.js: Middleware / Proxy bypass in App Router applications using Turbopack and single locale (high 8.3)
- [CVE-2026-64645](https://insights.sbomify.com/CVE-2026-64645/): Next.js: Server-Side Request Forgery in rewrites via attacker-controlled destination hostname (high 8.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-27978 and fix it if it is affected.

What it is: CVE-2026-27978 is a medium-severity vulnerability in Vercel Next.js, published on 17 Mar 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-27978 in the wild and no public exploit code.

Affected packages and fixed versions:
- next (npm): affected from 16.0.1; fixed in 16.1.7
- next (npm): affected from 16.0.1; fixed in 16.1.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-27978/ (Markdown: https://insights.sbomify.com/CVE-2026-27978/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-27978
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-27978
- OSV: https://osv.dev/vulnerability/CVE-2026-27978

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-27978/
Summaries are generated and may contain mistakes; the official description above is the record.
