CVE-2026-27979 Next.js: Unbounded postponed resume buffering can lead to DoS

Medium 6.9 Published Updated

Attackers can cause denial of service by sending oversized payloads in Next.js apps with Partial Prerendering enabled, exhausting server memory.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-27979?

CVE-2026-27979 is a medium-severity denial of service vulnerability in Vercel Next.js, published on 18 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Next.js is a React framework for building full-stack web applications. Starting in version 16.0.1 and prior to version 16.1.7, a request containing the `next-resume: 1` header (corresponding with a PPR resume request) would buffer request bodies without consistently enforcing `maxPostponedStateSize` in certain setups. The previous mitigation protected minimal-mode deployments, but equivalent non-minimal deployments remained vulnerable to the same unbounded postponed resume-body buffering behavior. In applications using the App Router with Partial Prerendering capability enabled (via `experimental.ppr` or `cacheComponents`), an attacker could send oversized `next-resume` POST payloads that were buffered without consistent size enforcement in non-minimal deployments, causing excessive memory usage and potential denial of service. This is fixed in version 16.1.7 by enforcing size limits across all postponed-body buffering paths and erroring when limits are exceeded. If upgrading is not immediately possible, block requests containing the `next-resume` header, as this is never valid to be sent from an untrusted client.

Weakness: CWE-770

Which versions are affected by CVE-2026-27979?

2 open source packages ship an affected version, including next. It affects 1 product.

PackageAffectedFixed in
next npmFrom 16.0.116.1.7
next npmFrom 16.0.116.1.7

Products include Vercel Next.js.

How do I fix CVE-2026-27979?

Upgrade next to 16.1.7 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2026-27979 being exploited?

There is no known exploitation of CVE-2026-27979 in the wild and no public exploit code.

All Vercel Next.js vulnerabilities

Sources

Also known as GHSA-h27x-g6w4-24gq, MINI-qxg3-4rjw-64vp, MINI-r8qw-m43q-456p, ROOT-APP-NPM-CVE-2026-27979.

Is CVE-2026-27979 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free