# CVE-2026-27979: Next.js: Unbounded postponed resume buffering can lead to DoS

> Attackers can cause denial of service by sending oversized payloads in Next.js apps with Partial Prerendering enabled, exhausting server memory.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Mar 2026
- **Updated:** 18 Mar 2026
- **Also known as:** GHSA-h27x-g6w4-24gq, MINI-qxg3-4rjw-64vp, MINI-r8qw-m43q-456p, ROOT-APP-NPM-CVE-2026-27979

## What is CVE-2026-27979?

CVE-2026-27979 is a medium-severity denial of service vulnerability in Vercel Next.js, published on 18 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Next.js is a React framework for building full-stack web applications. Starting in version 16.0.1 and prior to version 16.1.7, a request containing the `next-resume: 1` header (corresponding with a PPR resume request) would buffer request bodies without consistently enforcing `maxPostponedStateSize` in certain setups. The previous mitigation protected minimal-mode deployments, but equivalent non-minimal deployments remained vulnerable to the same unbounded postponed resume-body buffering behavior. In applications using the App Router with Partial Prerendering capability enabled (via `experimental.ppr` or `cacheComponents`), an attacker could send oversized `next-resume` POST payloads that were buffered without consistent size enforcement in non-minimal deployments, causing excessive memory usage and potential denial of service. This is fixed in version 16.1.7 by enforcing size limits across all postponed-body buffering paths and erroring when limits are exceeded. If upgrading is not immediately possible, block requests containing the `next-resume` header, as this is never valid to be sent from an untrusted client.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2026-27979?

2 open source packages ship an affected version, including next. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `next` | npm | From 16.0.1 | 16.1.7 |
| `next` | npm | From 16.0.1 | 16.1.7 |

Products: Vercel Next.js.

## How do I fix CVE-2026-27979?

Upgrade next to 16.1.7 or later.

## Is CVE-2026-27979 being exploited?

There is no known exploitation of CVE-2026-27979 in the wild and no public exploit code.

## Other vulnerabilities in Vercel Next.js

- [CVE-2025-29927](https://insights.sbomify.com/CVE-2025-29927/): Authorization Bypass in Next.js Middleware (critical 9.1)
- [CVE-2026-44578](https://insights.sbomify.com/CVE-2026-44578/): Next.js: Server-side request forgery in applications using WebSocket upgrades (high 8.6)
- [CVE-2026-94483](https://insights.sbomify.com/CVE-2026-94483/): Next.js: Server-Side Request Forgery in Image Optimization (high 8.3)
- [CVE-2026-64642](https://insights.sbomify.com/CVE-2026-64642/): Next.js: Middleware / Proxy bypass in App Router applications using Turbopack and single locale (high 8.3)
- [CVE-2026-64645](https://insights.sbomify.com/CVE-2026-64645/): Next.js: Server-Side Request Forgery in rewrites via attacker-controlled destination hostname (high 8.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-27979 and fix it if it is affected.

What it is: CVE-2026-27979 is a medium-severity denial of service vulnerability in Vercel Next.js, published on 18 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-27979 in the wild and no public exploit code.

Affected packages and fixed versions:
- next (npm): affected from 16.0.1; fixed in 16.1.7
- next (npm): affected from 16.0.1; fixed in 16.1.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-27979/ (Markdown: https://insights.sbomify.com/CVE-2026-27979/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-27979
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-27979
- OSV: https://osv.dev/vulnerability/CVE-2026-27979

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-27979/
Summaries are generated and may contain mistakes; the official description above is the record.
