# CVE-2026-27980: Next.js: Unbounded next/image disk cache growth can exhaust storage

> Attackers can exhaust disk space by generating unique image variants, causing denial of service in Next.js applications.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Mar 2026
- **Updated:** 18 Mar 2026
- **Also known as:** CLEANSTART-2026-DI49367, CLEANSTART-2026-LS37320, GHSA-3x4c-7xq6-9pq8, MINI-7r6h-fggg-hg3j, MINI-v227-w5cp-m84h, MINI-vpp7-6fjq-88wp, ROOT-APP-NPM-CVE-2026-27980

## What is CVE-2026-27980?

CVE-2026-27980 is a medium-severity denial of service vulnerability in Vercel Next.js, published on 18 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Next.js is a React framework for building full-stack web applications. Starting in version 10.0.0 and prior to version 16.1.7, the default Next.js image optimization disk cache (`/_next/image`) did not have a configurable upper bound, allowing unbounded cache growth. An attacker could generate many unique image-optimization variants and exhaust disk space, causing denial of service. This is fixed in version 16.1.7 by adding an LRU-backed disk cache with `images.maximumDiskCacheSize`, including eviction of least-recently-used entries when the limit is exceeded. Setting `maximumDiskCacheSize: 0` disables disk caching. If upgrading is not immediately possible, periodically clean `.next/cache/images` and/or reduce variant cardinality (e.g., tighten values for `images.localPatterns`, `images.remotePatterns`, and `images.qualities`).

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-27980?

4 open source packages ship an affected version, including next. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `next` | npm | From 10.0.0 | 15.5.14 |
| `next` | npm | From 10.0.0 | 15.5.14 |
| `next` | npm | From 16.0.0-beta.0 | 16.1.7 |
| `next` | npm | From 16.0.0-beta.0 | 16.1.7 |

Products: Vercel Next.js.

## How do I fix CVE-2026-27980?

Upgrade next to a fixed version for your release line: 15.5.14 or 16.1.7.

## Is CVE-2026-27980 being exploited?

There is no known exploitation of CVE-2026-27980 in the wild and no public exploit code.

## Other vulnerabilities in Vercel Next.js

- [CVE-2025-29927](https://insights.sbomify.com/CVE-2025-29927/): Authorization Bypass in Next.js Middleware (critical 9.1)
- [CVE-2026-44578](https://insights.sbomify.com/CVE-2026-44578/): Next.js: Server-side request forgery in applications using WebSocket upgrades (high 8.6)
- [CVE-2026-94483](https://insights.sbomify.com/CVE-2026-94483/): Next.js: Server-Side Request Forgery in Image Optimization (high 8.3)
- [CVE-2026-64642](https://insights.sbomify.com/CVE-2026-64642/): Next.js: Middleware / Proxy bypass in App Router applications using Turbopack and single locale (high 8.3)
- [CVE-2026-64645](https://insights.sbomify.com/CVE-2026-64645/): Next.js: Server-Side Request Forgery in rewrites via attacker-controlled destination hostname (high 8.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-27980 and fix it if it is affected.

What it is: CVE-2026-27980 is a medium-severity denial of service vulnerability in Vercel Next.js, published on 18 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-27980 in the wild and no public exploit code.

Affected packages and fixed versions:
- next (npm): affected from 10.0.0; fixed in 15.5.14
- next (npm): affected from 10.0.0; fixed in 15.5.14
- next (npm): affected from 16.0.0-beta.0; fixed in 16.1.7
- next (npm): affected from 16.0.0-beta.0; fixed in 16.1.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-27980/ (Markdown: https://insights.sbomify.com/CVE-2026-27980/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-27980
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-27980
- OSV: https://osv.dev/vulnerability/CVE-2026-27980

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-27980/
Summaries are generated and may contain mistakes; the official description above is the record.
