# CVE-2026-27982: django-allauth has an open redirect vulnerability

> Attackers can redirect users to malicious sites via crafted URLs when SAML IdP initiated SSO is enabled in django-allauth.

- **Severity:** Medium 5.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 5 Mar 2026
- **Updated:** 6 Mar 2026
- **Also known as:** DEBIAN-CVE-2026-27982, GHSA-2jpr-83rg-v67j, PYSEC-2026-56, UBUNTU-CVE-2026-27982

## What is CVE-2026-27982?

CVE-2026-27982 is a medium-severity vulnerability in django-allauth, published on 5 Mar 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

An open redirect vulnerability exists in django-allauth versions prior to 65.14.1 when SAML IdP initiated SSO is enabled (it is disabled by default), which may allow an attacker to redirect users to an arbitrary external website via a crafted URL.

Weakness: CWE-601 (URL Redirection to Untrusted Site)

## Which versions are affected by CVE-2026-27982?

3 open source packages ship an affected version, including django-allauth. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `django-allauth` | PyPI | All versions | 65.14.1 |
| `django-allauth` | PyPI | All versions | 65.14.1 |
| `django-allauth` | PyPI | All versions | 65.14.1 |

Products: Allauth Allauth.

## How do I fix CVE-2026-27982?

Upgrade django-allauth to 65.14.1 or later.

## Is CVE-2026-27982 being exploited?

There is no known exploitation of CVE-2026-27982 in the wild and no public exploit code.

## Other vulnerabilities in django-allauth

- [CVE-2025-65430](https://insights.sbomify.com/CVE-2025-65430/): django-allauth does not reject access tokens for inactive users (medium 5.4)
- [CVE-2025-65431](https://insights.sbomify.com/CVE-2025-65431/): django-allauth's Okta and NetIQ implementations used a mutable identifier for authorization decisions (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-27982 and fix it if it is affected.

What it is: CVE-2026-27982 is a medium-severity vulnerability in django-allauth, published on 5 Mar 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-27982 in the wild and no public exploit code.

Affected packages and fixed versions:
- django-allauth (PyPI): affected all versions; fixed in 65.14.1
- django-allauth (PyPI): affected all versions; fixed in 65.14.1
- django-allauth (PyPI): affected all versions; fixed in 65.14.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-27982/ (Markdown: https://insights.sbomify.com/CVE-2026-27982/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-27982
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-27982
- OSV: https://osv.dev/vulnerability/CVE-2026-27982

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-27982/
Summaries are generated and may contain mistakes; the official description above is the record.
