CVE-2026-28222 Wagtail: Improper escaping of HTML (Cross-site Scripting) on TableBlock class attributes
Stored XSS in Wagtail TableBlock allows privileged users to execute arbitrary JavaScript, potentially leading to account takeover.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2026-28222?
CVE-2026-28222 is a medium-severity cross-site scripting vulnerability in wagtail, published on 5 Mar 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Official description
Wagtail is an open source content management system built on Django. Prior to versions 6.3.8, 7.0.6, 7.2.3, and 7.3.1, a stored cross-site scripting (XSS) vulnerability exists on rendering TableBlock blocks within a StreamField. A user with access to create or edit pages containing TableBlock StreamField blocks is able to set specially-crafted class attributes on the block which run arbitrary JavaScript code when the page is viewed. When viewed by a user with higher privileges, this could lead to performing actions with that user's credentials. The vulnerability is not exploitable by an ordinary site visitor without access to the Wagtail admin, and only affects sites using TableBlock. This issue has been patched in versions 6.3.8, 7.0.6, 7.2.3, and 7.3.1.
Weakness: CWE-79
Which versions are affected by CVE-2026-28222?
9 open source packages ship an affected version, including wagtail. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
wagtail PyPI | All versions | 6.3.8, 7.0.6, 7.2.3 |
wagtail PyPI | All versions | 6.3.8 |
wagtail PyPI | All versions | 6.3.8 |
wagtail PyPI | From 6.4rc1 | 7.0.6 |
wagtail PyPI | From 6.4rc1 | 7.0.6 |
wagtail PyPI | From 7.1rc1 | 7.2.3 |
3 more packages
wagtail PyPI | From 7.1rc1 | 7.2.3 |
wagtail PyPI | From 7.3rc1 | 7.3.1 |
wagtail PyPI | From 7.3rc1 | 7.3.1 |
Products include Torchbox Wagtail.
How do I fix CVE-2026-28222?
Upgrade wagtail to a fixed version for your release line: 6.3.8, 7.0.6, 7.2.3 or 7.3.1.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2026-28222 being exploited?
There is no known exploitation of CVE-2026-28222 in the wild and no public exploit code.
Other vulnerabilities in wagtail
- CVE-2026-54263 Wagtail: Reflected XSS in dynamic image URL generator view
- CVE-2026-54261 Wagtail: Improper permission handling in image preview
- CVE-2026-44197 Wagtail: Improper permission handling when comparing revisions
- CVE-2026-44199 Wagtail: Improper permission handling when deleting form submissions
- CVE-2026-44200 Wagtail: Improper permission handling when copying pages
Sources
Also known as GHSA-p5cm-246w-84jm, PYSEC-2026-2307, ROOT-APP-PYPI-CVE-2026-28222.