CVE-2026-28223 Wagtail: Improper escaping of HTML (Cross-site Scripting) in simple_translation admin interface
Stored XSS in Wagtail admin allows attackers to execute JavaScript via crafted page titles, potentially hijacking other admin users' sessions.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2026-28223?
CVE-2026-28223 is a medium-severity cross-site scripting vulnerability in wagtail, published on 5 Mar 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Official description
Wagtail is an open source content management system built on Django. Prior to versions 6.3.8, 7.0.6, 7.2.3, and 7.3.1, a stored cross-site scripting (XSS) vulnerability exists on confirmation messages within the wagtail.contrib.simple_translation module. A user with access to the Wagtail admin area may create a page with a specially-crafted title which, when another user performs the "Translate" action, causes arbitrary JavaScript code to run. This could lead to performing actions with that user's credentials. The vulnerability is not exploitable by an ordinary site visitor without access to the Wagtail admin. This issue has been patched in versions 6.3.8, 7.0.6, 7.2.3, and 7.3.1.
Weakness: CWE-79
Which versions are affected by CVE-2026-28223?
9 open source packages ship an affected version, including wagtail. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
wagtail PyPI | All versions | 6.3.8, 7.0.6, 7.2.3 |
wagtail PyPI | All versions | 6.3.8 |
wagtail PyPI | All versions | 6.3.8 |
wagtail PyPI | From 6.4rc1 | 7.0.6 |
wagtail PyPI | From 6.4rc1 | 7.0.6 |
wagtail PyPI | From 7.1rc1 | 7.2.3 |
3 more packages
wagtail PyPI | From 7.1rc1 | 7.2.3 |
wagtail PyPI | From 7.3rc1 | 7.3.1 |
wagtail PyPI | From 7.3rc1 | 7.3.1 |
Products include Torchbox Wagtail.
How do I fix CVE-2026-28223?
Upgrade wagtail to a fixed version for your release line: 6.3.8, 7.0.6, 7.2.3 or 7.3.1.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2026-28223 being exploited?
There is no known exploitation of CVE-2026-28223 in the wild and no public exploit code.
Other vulnerabilities in wagtail
- CVE-2026-54263 Wagtail: Reflected XSS in dynamic image URL generator view
- CVE-2026-54261 Wagtail: Improper permission handling in image preview
- CVE-2026-44197 Wagtail: Improper permission handling when comparing revisions
- CVE-2026-44199 Wagtail: Improper permission handling when deleting form submissions
- CVE-2026-44200 Wagtail: Improper permission handling when copying pages
Sources
Also known as GHSA-p4v8-rw59-93cq, PYSEC-2026-2308, ROOT-APP-PYPI-CVE-2026-28223.