# CVE-2026-28223: Wagtail: Improper escaping of HTML (Cross-site Scripting) in simple_translation admin interface

> Stored XSS in Wagtail admin allows attackers to execute JavaScript via crafted page titles, potentially hijacking other admin users' sessions.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 5 Mar 2026
- **Updated:** 6 Mar 2026
- **Also known as:** GHSA-p4v8-rw59-93cq, PYSEC-2026-2308, ROOT-APP-PYPI-CVE-2026-28223

## What is CVE-2026-28223?

CVE-2026-28223 is a medium-severity cross-site scripting vulnerability in wagtail, published on 5 Mar 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

Wagtail is an open source content management system built on Django. Prior to versions 6.3.8, 7.0.6, 7.2.3, and 7.3.1, a stored cross-site scripting (XSS) vulnerability exists on confirmation messages within the wagtail.contrib.simple_translation module. A user with access to the Wagtail admin area may create a page with a specially-crafted title which, when another user performs the "Translate" action, causes arbitrary JavaScript code to run. This could lead to performing actions with that user's credentials. The vulnerability is not exploitable by an ordinary site visitor without access to the Wagtail admin. This issue has been patched in versions 6.3.8, 7.0.6, 7.2.3, and 7.3.1.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-28223?

9 open source packages ship an affected version, including wagtail. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `wagtail` | PyPI | All versions | 6.3.8, 7.0.6, 7.2.3 |
| `wagtail` | PyPI | All versions | 6.3.8 |
| `wagtail` | PyPI | All versions | 6.3.8 |
| `wagtail` | PyPI | From 6.4rc1 | 7.0.6 |
| `wagtail` | PyPI | From 6.4rc1 | 7.0.6 |
| `wagtail` | PyPI | From 7.1rc1 | 7.2.3 |
| `wagtail` | PyPI | From 7.1rc1 | 7.2.3 |
| `wagtail` | PyPI | From 7.3rc1 | 7.3.1 |
| `wagtail` | PyPI | From 7.3rc1 | 7.3.1 |

Products: Torchbox Wagtail.

## How do I fix CVE-2026-28223?

Upgrade wagtail to a fixed version for your release line: 6.3.8, 7.0.6, 7.2.3 or 7.3.1.

## Is CVE-2026-28223 being exploited?

There is no known exploitation of CVE-2026-28223 in the wild and no public exploit code.

## Other vulnerabilities in wagtail

- [CVE-2026-54263](https://insights.sbomify.com/CVE-2026-54263/): Wagtail: Reflected XSS in dynamic image URL generator view (high 7.3)
- [CVE-2026-54261](https://insights.sbomify.com/CVE-2026-54261/): Wagtail: Improper permission handling in image preview (medium 6.5)
- [CVE-2026-44197](https://insights.sbomify.com/CVE-2026-44197/): Wagtail: Improper permission handling when comparing revisions (medium 6.5)
- [CVE-2026-44199](https://insights.sbomify.com/CVE-2026-44199/): Wagtail: Improper permission handling when deleting form submissions (medium 6.5)
- [CVE-2026-44200](https://insights.sbomify.com/CVE-2026-44200/): Wagtail: Improper permission handling when copying pages (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-28223 and fix it if it is affected.

What it is: CVE-2026-28223 is a medium-severity cross-site scripting vulnerability in wagtail, published on 5 Mar 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-28223 in the wild and no public exploit code.

Affected packages and fixed versions:
- wagtail (PyPI): affected all versions; fixed in 6.3.8, 7.0.6, 7.2.3
- wagtail (PyPI): affected all versions; fixed in 6.3.8
- wagtail (PyPI): affected all versions; fixed in 6.3.8
- wagtail (PyPI): affected from 6.4rc1; fixed in 7.0.6
- wagtail (PyPI): affected from 6.4rc1; fixed in 7.0.6
- wagtail (PyPI): affected from 7.1rc1; fixed in 7.2.3
- wagtail (PyPI): affected from 7.1rc1; fixed in 7.2.3
- wagtail (PyPI): affected from 7.3rc1; fixed in 7.3.1
- wagtail (PyPI): affected from 7.3rc1; fixed in 7.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-28223/ (Markdown: https://insights.sbomify.com/CVE-2026-28223/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-28223
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-28223
- OSV: https://osv.dev/vulnerability/CVE-2026-28223

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-28223/
Summaries are generated and may contain mistakes; the official description above is the record.
