CVE-2026-28227 Discourse Vulnerable to Unauthorized Topic Creation in Staff-Only Categories via Topic Timer publish_to_category

Low 1.2 Published Updated

TL4 users can bypass authorization checks to publish topics into staff-only categories using the topic timer feature.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-28227?

CVE-2026-28227 is a low-severity missing authorization vulnerability in Discourse Discourse, published on 26 Feb 2026. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

Discourse is an open source discussion platform. Prior to versions 2025.12.2, 2026.1.1, and 2026.2.0, TL4 users can publish topics into staff-only categories via the `publish_to_category` topic timer, bypassing authorization checks. Versions 2025.12.2, 2026.1.1, and 2026.2.0 patch the issue. No known workarounds are available.

Weakness: CWE-863

Which versions are affected by CVE-2026-28227?

1 open source package ship an affected version, including discourse. It affects 1 product.

PackageAffectedFixed in
discourse BitnamiAll versions2025.12.2, 2026.1.1

Products include Discourse Discourse.

How do I fix CVE-2026-28227?

Upgrade discourse to a fixed version for your release line: 2025.12.2 or 2026.1.1.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2026-28227 being exploited?

There is no known exploitation of CVE-2026-28227 in the wild and no public exploit code.

All Discourse Discourse vulnerabilities

Sources

Also known as BIT-discourse-2026-28227, GHSA-m49w-78mh-87jp.

Is CVE-2026-28227 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free