# CVE-2026-28275: Initiative Vulnerable to Improper Session Invalidation (JWT Remains Valid)

> Attackers can retain access via old JWTs after password changes, bypassing session invalidation in Initiative project management platform.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 26 Feb 2026
- **Updated:** 27 Feb 2026
- **Also known as:** GHSA-hww6-3fww-xw3h

## What is CVE-2026-28275?

CVE-2026-28275 is a high-severity vulnerability in Morelitea initiative, published on 26 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Initiative is a self-hosted project management platform. Versions of the application prior to 0.32.4 do not invalidate previously issued JWT access tokens after a user changes their password. As a result, older tokens remain valid until expiration and can still be used to access protected API endpoints. This behavior allows continued authenticated access even after the account password has been updated. Version 0.32.4 fixes the issue.

Weakness: CWE-613 (DEPRECATED: Insufficient Session Expiration)

## Which versions are affected by CVE-2026-28275?

It affects 1 product.


Products: Morelitea Initiative.

## How do I fix CVE-2026-28275?

No fix has been published for CVE-2026-28275 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-28275 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-28275 exists.

## Other vulnerabilities in Morelitea initiative

- [CVE-2026-28274](https://insights.sbomify.com/CVE-2026-28274/): Initiative Vulnerable to Token Theft via Stored XSS in Document Uploads (high 8.7)
- [CVE-2026-28276](https://insights.sbomify.com/CVE-2026-28276/): Initiative Allows Unauthenticated Access to Uploaded Documents via Public /uploads/ Endpoint (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-28275 and fix it if it is affected.

What it is: CVE-2026-28275 is a high-severity vulnerability in Morelitea initiative, published on 26 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-28275 exists.

Affected product: Morelitea initiative. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-28275/ (Markdown: https://insights.sbomify.com/CVE-2026-28275/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-28275
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-28275
- OSV: https://osv.dev/vulnerability/CVE-2026-28275

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-28275/
Summaries are generated and may contain mistakes; the official description above is the record.
