{"answers":{"affected":"3 open source packages ship an affected version, including langgraph. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-28277 in the wild and no public exploit code.","fix":"Upgrade langgraph to a fixed version for your release line: 1.0.10 or 1.0.10rc1.","what":"CVE-2026-28277 is a medium-severity unsafe deserialization vulnerability in langchain-ai langgraph, published on 5 Mar 2026. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-28277 and fix it if it is affected.\n\nWhat it is: CVE-2026-28277 is a medium-severity unsafe deserialization vulnerability in langchain-ai langgraph, published on 5 Mar 2026. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-28277 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- langgraph (PyPI): affected all versions; fixed in 1.0.10\n- langgraph (PyPI): affected all versions; fixed in 1.0.10\n- langgraph (PyPI): affected all versions; fixed in 1.0.10rc1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-28277/ (Markdown: https://insights.sbomify.com/CVE-2026-28277/index.md)","id":"CVE-2026-28277","markdown":"https://insights.sbomify.com/CVE-2026-28277/index.md","name":"CVE-2026-28277","record":{"aliases":["ECHO-3081-02d6-65ad","GHSA-g48c-2wqr-h844","PYSEC-2026-83"],"analysis":{"component_type":"library","fix_type":"no_fix_stated","impacts":["code_execution"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"LangGraph checkpoint library","requires_auth":"high_privilege","summary":"Attackers with write access to the checkpoint database can execute arbitrary code via unsafe msgpack deserialization in LangGraph.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"langgraph","vendor":"langchain"}],"cvss":{"score":6.8,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:A/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-502","name":"Deserialization of Untrusted Data"}],"description":"LangGraph SQLite Checkpoint is an implementation of LangGraph CheckpointSaver that uses SQLite DB (both sync and async, via aiosqlite). In version 1.0.9 and prior, LangGraph checkpointers can load msgpack-encoded checkpoints that reconstruct Python objects during deserialization. If an attacker can modify checkpoint data in the backing store (for example, after a database compromise or other privileged write access to the persistence layer), they can potentially supply a crafted payload that triggers unsafe object reconstruction when the checkpoint is loaded. No known patch is public.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"LangGraph: Unsafe msgpack deserialization in LangGraph checkpoint loading","id":"CVE-2026-28277","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"deserialization","year":"2026"},"n_packages":3,"n_references":1,"next":{"headline":"`osctrl-admin` Vulnerable to OS Command Injection via Environment Configuration","id":"CVE-2026-28279"},"packages":[{"ecosystem":"PyPI","fixed":["1.0.10"],"introduced":["0"],"last_affected":[],"package":"langgraph","purl":null,"source":"GHSA-g48c-2wqr-h844"},{"ecosystem":"PyPI","fixed":["1.0.10"],"introduced":["0"],"last_affected":[],"package":"langgraph","purl":"pkg:pypi/langgraph","source":"GHSA-g48c-2wqr-h844"},{"ecosystem":"PyPI","fixed":["1.0.10rc1"],"introduced":["0"],"last_affected":[],"package":"langgraph","purl":"pkg:pypi/langgraph","source":"PYSEC-2026-83"}],"prev":{"headline":"Initiative Allows Unauthenticated Access to Uploaded Documents via Public /uploads/ Endpoint","id":"CVE-2026-28276"},"products":["langgraph"],"published":"2026-03-05","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-03-06","vendors":["langchain-ai"]},"summary":"Attackers with write access to the checkpoint database can execute arbitrary code via unsafe msgpack deserialization in LangGraph.","url":"https://insights.sbomify.com/CVE-2026-28277/"}