# CVE-2026-28277: LangGraph: Unsafe msgpack deserialization in LangGraph checkpoint loading

> Attackers with write access to the checkpoint database can execute arbitrary code via unsafe msgpack deserialization in LangGraph.

- **Severity:** Medium 6.8 (`CVSS:3.1/AV:A/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Mar 2026
- **Updated:** 6 Mar 2026
- **Also known as:** ECHO-3081-02d6-65ad, GHSA-g48c-2wqr-h844, PYSEC-2026-83

## What is CVE-2026-28277?

CVE-2026-28277 is a medium-severity unsafe deserialization vulnerability in langchain-ai langgraph, published on 5 Mar 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

LangGraph SQLite Checkpoint is an implementation of LangGraph CheckpointSaver that uses SQLite DB (both sync and async, via aiosqlite). In version 1.0.9 and prior, LangGraph checkpointers can load msgpack-encoded checkpoints that reconstruct Python objects during deserialization. If an attacker can modify checkpoint data in the backing store (for example, after a database compromise or other privileged write access to the persistence layer), they can potentially supply a crafted payload that triggers unsafe object reconstruction when the checkpoint is loaded. No known patch is public.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2026-28277?

3 open source packages ship an affected version, including langgraph. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `langgraph` | PyPI | All versions | 1.0.10 |
| `langgraph` | PyPI | All versions | 1.0.10 |
| `langgraph` | PyPI | All versions | 1.0.10rc1 |

Products: Langchain Langgraph.

## How do I fix CVE-2026-28277?

Upgrade langgraph to a fixed version for your release line: 1.0.10 or 1.0.10rc1.

## Is CVE-2026-28277 being exploited?

There is no known exploitation of CVE-2026-28277 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-28277 and fix it if it is affected.

What it is: CVE-2026-28277 is a medium-severity unsafe deserialization vulnerability in langchain-ai langgraph, published on 5 Mar 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-28277 in the wild and no public exploit code.

Affected packages and fixed versions:
- langgraph (PyPI): affected all versions; fixed in 1.0.10
- langgraph (PyPI): affected all versions; fixed in 1.0.10
- langgraph (PyPI): affected all versions; fixed in 1.0.10rc1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-28277/ (Markdown: https://insights.sbomify.com/CVE-2026-28277/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-28277
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-28277
- OSV: https://osv.dev/vulnerability/CVE-2026-28277

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-28277/
Summaries are generated and may contain mistakes; the official description above is the record.
