# CVE-2026-28279: `osctrl-admin` Vulnerable to OS Command Injection via Environment Configuration

> An authenticated administrator can inject shell commands via the hostname parameter, leading to remote code execution as root on all enrolling endpoints.

- **Severity:** High 7.4 (`CVSS:3.1/AV:A/AC:H/PR:H/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 26 Feb 2026
- **Updated:** 27 Feb 2026
- **Also known as:** GHSA-rchw-322g-f7rm, GO-2026-4579

## What is CVE-2026-28279?

CVE-2026-28279 is a high-severity command injection vulnerability in jmpsec osctrl, published on 26 Feb 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

osctrl is an osquery management solution. Prior to version 0.5.0, an OS command injection vulnerability exists in the `osctrl-admin` environment configuration. An authenticated administrator can inject arbitrary shell commands via the hostname parameter when creating or editing environments. These commands are embedded into enrollment one-liner scripts generated using Go's `text/template` package (which does not perform shell escaping) and execute on every endpoint that enrolls using the compromised environment. An attacker with administrator access can achieve remote code execution on every endpoint that enrolls using the compromised environment. Commands execute as root/SYSTEM (the privilege level used for osquery enrollment) before osquery is installed, leaving no agent-level audit trail. This enables backdoor installation, credential exfiltration, and full endpoint compromise. This is fixed in osctrl `v0.5.0`. As a workaround, restrict osctrl administrator access to trusted personnel, review existing environment configurations for suspicious hostnames, and/or monitor enrollment scripts for unexpected commands.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2026-28279?

3 open source packages ship an affected version, including github.com/jmpsec/osctrl. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/jmpsec/osctrl` | Go | All versions | 0.5.0 |
| `github.com/jmpsec/osctrl` | Go | All versions | 0.5.0 |
| `github.com/jmpsec/osctrl` | Go | All versions | 0.5.0 |

Products: Jmpsec Osctrl.

## How do I fix CVE-2026-28279?

Upgrade github.com/jmpsec/osctrl to 0.5.0 or later.

## Is CVE-2026-28279 being exploited?

There is no known exploitation of CVE-2026-28279 in the wild and no public exploit code.

## Other vulnerabilities in jmpsec osctrl

- [CVE-2026-28280](https://insights.sbomify.com/CVE-2026-28280/): `osctrl-admin` has Stored Cross-Site Scripting (XSS) in On-Demand Query List (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-28279 and fix it if it is affected.

What it is: CVE-2026-28279 is a high-severity command injection vulnerability in jmpsec osctrl, published on 26 Feb 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-28279 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/jmpsec/osctrl (Go): affected all versions; fixed in 0.5.0
- github.com/jmpsec/osctrl (Go): affected all versions; fixed in 0.5.0
- github.com/jmpsec/osctrl (Go): affected all versions; fixed in 0.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-28279/ (Markdown: https://insights.sbomify.com/CVE-2026-28279/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-28279
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-28279
- OSV: https://osv.dev/vulnerability/CVE-2026-28279

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-28279/
Summaries are generated and may contain mistakes; the official description above is the record.
