# CVE-2026-28280: `osctrl-admin` has Stored Cross-Site Scripting (XSS) in On-Demand Query List

> A stored XSS in osctrl-admin allows low-privilege users to execute JavaScript in administrators' browsers, potentially leading to full platform compromise.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 26 Feb 2026
- **Updated:** 2 Mar 2026
- **Also known as:** GHSA-4rv8-5cmm-2r22, GO-2026-4576

## What is CVE-2026-28280?

CVE-2026-28280 is a medium-severity cross-site scripting vulnerability in jmpsec osctrl, published on 26 Feb 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

osctrl is an osquery management solution. Prior to version 0.5.0, a stored cross-site scripting (XSS) vulnerability exists in the `osctrl-admin` on-demand query list. A user with query-level permissions can inject arbitrary JavaScript via the query parameter when running an on-demand query. The payload is stored and executes in the browser of any user (including administrators) who visits the query list page. This can be chained with CSRF token extraction to escalate privileges and take actions as the logged in user. An attacker with query-level permissions (the lowest privilege tier) can execute arbitrary JavaScript in the browsers of all users who view the query list. Depending on their level of access, it can lead to full platform compromise if an administrator executes the payload. The issue is fixed in osctrl `v0.5.0`. As a workaround, restrict query-level permissions to trusted users, monitor query list for suspicious payloads, and/or review osctrl user accounts for unauthorized administrators.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-28280?

3 open source packages ship an affected version, including github.com/jmpsec/osctrl. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/jmpsec/osctrl` | Go | All versions | 0.5.0 |
| `github.com/jmpsec/osctrl` | Go | All versions | 0.5.0 |
| `github.com/jmpsec/osctrl` | Go | All versions | 0.5.0 |

Products: Jmpsec Osctrl.

## How do I fix CVE-2026-28280?

Upgrade github.com/jmpsec/osctrl to 0.5.0 or later.

## Is CVE-2026-28280 being exploited?

There is no known exploitation of CVE-2026-28280 in the wild and no public exploit code.

## Other vulnerabilities in jmpsec osctrl

- [CVE-2026-28279](https://insights.sbomify.com/CVE-2026-28279/): `osctrl-admin` Vulnerable to OS Command Injection via Environment Configuration (high 7.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-28280 and fix it if it is affected.

What it is: CVE-2026-28280 is a medium-severity cross-site scripting vulnerability in jmpsec osctrl, published on 26 Feb 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-28280 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/jmpsec/osctrl (Go): affected all versions; fixed in 0.5.0
- github.com/jmpsec/osctrl (Go): affected all versions; fixed in 0.5.0
- github.com/jmpsec/osctrl (Go): affected all versions; fixed in 0.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-28280/ (Markdown: https://insights.sbomify.com/CVE-2026-28280/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-28280
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-28280
- OSV: https://osv.dev/vulnerability/CVE-2026-28280

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-28280/
Summaries are generated and may contain mistakes; the official description above is the record.
