CVE-2026-28287 FreePBX: Authenticated Remote Code Execution via Recordings Module AJAX Endpoints
Authenticated attackers can execute arbitrary commands via the recordings module in FreePBX, requiring an upgrade to patched versions.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2026-28287?
CVE-2026-28287 is a high-severity command injection vulnerability in Sangoma Freepbx, published on 5 Mar 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
FreePBX is an open source IP PBX. From versions 16.0.17.2 to before 16.0.20 and from version 17.0.2.4 to before 17.0.5, multiple command injection vulnerabilities exist in the recordings module. This issue has been patched in versions 16.0.20 and 17.0.5.
Weakness: CWE-78
Which versions are affected by CVE-2026-28287?
It affects 1 product.
Products include Sangoma Freepbx.
How do I fix CVE-2026-28287?
No fix has been published for CVE-2026-28287 yet. Limit exposure of the affected software until one is available.
Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.
Is CVE-2026-28287 being exploited?
There is no known exploitation of CVE-2026-28287 in the wild and no public exploit code.
Other vulnerabilities in Sangoma Freepbx
- CVE-2025-57819 Sangoma FreePBX Authentication Bypass
- CVE-2019-19006 Sangoma FreePBX Improper Authentication
- CVE-2026-73663 FreePBX: Unauthenticated SQL injection in FreePBX missedcall via inbound Caller ID name leads to administrator takeover
- CVE-2026-73665 FreePBX UCP: Unauthenticated remote code execution via socket.io namespace auth bypass and AMI action injection
- CVE-2026-46376 FreePBX: Unauthenticated Use of Hard-Coded Credentials Vulnerability in FreePBX UCP Interface
Sources
Also known as GHSA-9vv6-h8v6-rp4q.