{"answers":{"affected":"2 open source packages ship an affected version, including simple-git. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-28292 exists.","fix":"Upgrade simple-git to 3.32.3 or later.","what":"CVE-2026-28292 is a critical command injection vulnerability in steveukx simple-git, published on 10 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-28292 and fix it if it is affected.\n\nWhat it is: CVE-2026-28292 is a critical command injection vulnerability in steveukx simple-git, published on 10 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-28292 exists.\n\nAffected packages and fixed versions:\n- simple-git (npm): affected from 3.15.0; fixed in 3.32.3\n- simple-git (npm): affected from 3.15.0; fixed in 3.32.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-28292/ (Markdown: https://insights.sbomify.com/CVE-2026-28292/index.md)","id":"CVE-2026-28292","markdown":"https://insights.sbomify.com/CVE-2026-28292/index.md","name":"CVE-2026-28292","record":{"aliases":["CLEANSTART-2026-AL17033","CLEANSTART-2026-FN02943","GHSA-r275-fr43-pm7q","MINI-prqw-qwhg-g9p5","ROOT-APP-NPM-CVE-2026-28292","openSUSE-SU-2026:10327-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js git library","requires_auth":"none","summary":"Attackers can bypass security plugins in simple-git to achieve remote code execution on the host machine via case-insensitive configuration keys.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"simple-git","vendor":"simple-git_project"}],"cvss":{"score":9.8,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-78","name":"Improper Neutralization of Special Elements used in an OS Command"},{"id":"CWE-76","name":"Improper Neutralization of Equivalent Special Elements"},{"id":"CWE-178","name":"Improper Handling of Case Sensitivity"}],"description":"`simple-git`, an interface for running git commands in any node.js application, has an issue in versions 3.15.0 through 3.32.2 that allows an attacker to bypass two prior CVE fixes (CVE-2022-25860 and CVE-2022-25912) and achieve full remote code execution on the host machine. Version 3.23.0 contains an updated fix for the vulnerability.","ecosystems":["npm","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"simple-git has blockUnsafeOperationsPlugin bypass via case-insensitive protocol.allow config key that enables RCE","id":"CVE-2026-28292","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"command_injection","year":"2026"},"n_packages":3,"n_references":3,"next":{"headline":"Gvfs: gvfs ftp backend: information disclosure via untrusted pasv responses","id":"CVE-2026-28295"},"packages":[{"ecosystem":"npm","fixed":["3.32.3"],"introduced":["3.15.0"],"last_affected":[],"package":"simple-git","purl":null,"source":"GHSA-r275-fr43-pm7q"},{"ecosystem":"npm","fixed":["3.32.3"],"introduced":["3.15.0"],"last_affected":[],"package":"simple-git","purl":"pkg:npm/simple-git","source":"GHSA-r275-fr43-pm7q"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["2.20.1-3.1"],"introduced":["0"],"last_affected":[],"package":"heroic-games-launcher","purl":"pkg:rpm/opensuse/heroic-games-launcher\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2026:10327-1"}],"prev":{"headline":"simple-git has Command Execution via Option-Parsing Bypass","id":"CVE-2026-28291"},"products":["simple-git"],"published":"2026-03-10","related":[{"cvss_score":9.2,"headline":"simple-git unsafe-operation guard does not block trailer command configuration","id":"CVE-2026-102828","kev_date_added":null,"published":"2026-09-29"},{"cvss_score":9.2,"headline":"simple-git is vulnerable to Remote Code Execution","id":"CVE-2026-6951","kev_date_added":null,"published":"2026-04-25"},{"cvss_score":8.1,"headline":"simple-git allows command execution through unblocked Git configuration includes","id":"CVE-2026-102826","kev_date_added":null,"published":"2026-09-29"},{"cvss_score":8.1,"headline":"simple-git: unsafe-operations plugin bypass via git long-option abbreviation (--receive-p/--exe) -\u003e command execution (residual of CVE-2026-28291)","id":"CVE-2026-102827","kev_date_added":null,"published":"2026-09-29"},{"cvss_score":8.1,"headline":"simple-git has Command Execution via Option-Parsing Bypass","id":"CVE-2026-28291","kev_date_added":null,"published":"2026-04-13"},{"cvss_score":8.1,"headline":"Remote code execution in simple-git","id":"CVE-2022-25860","kev_date_added":null,"published":"2023-01-24"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-07-15","vendors":["steveukx"]},"summary":"Attackers can bypass security plugins in simple-git to achieve remote code execution on the host machine via case-insensitive configuration keys.","url":"https://insights.sbomify.com/CVE-2026-28292/"}