# CVE-2026-28292: simple-git has blockUnsafeOperationsPlugin bypass via case-insensitive protocol.allow config key that enables RCE

> Attackers can bypass security plugins in simple-git to achieve remote code execution on the host machine via case-insensitive configuration keys.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Mar 2026
- **Updated:** 15 Jul 2026
- **Also known as:** CLEANSTART-2026-AL17033, CLEANSTART-2026-FN02943, GHSA-r275-fr43-pm7q, MINI-prqw-qwhg-g9p5, ROOT-APP-NPM-CVE-2026-28292, openSUSE-SU-2026:10327-1

## What is CVE-2026-28292?

CVE-2026-28292 is a critical command injection vulnerability in steveukx simple-git, published on 10 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

`simple-git`, an interface for running git commands in any node.js application, has an issue in versions 3.15.0 through 3.32.2 that allows an attacker to bypass two prior CVE fixes (CVE-2022-25860 and CVE-2022-25912) and achieve full remote code execution on the host machine. Version 3.23.0 contains an updated fix for the vulnerability.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command), CWE-76 (Improper Neutralization of Equivalent Special Elements), CWE-178 (Improper Handling of Case Sensitivity)

## Which versions are affected by CVE-2026-28292?

2 open source packages ship an affected version, including simple-git. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `simple-git` | npm | From 3.15.0 | 3.32.3 |
| `simple-git` | npm | From 3.15.0 | 3.32.3 |
| `heroic-games-launcher` | openSUSE:Tumbleweed | All versions | 2.20.1-3.1 |

Products: Simple-Git Project Simple-Git.

## How do I fix CVE-2026-28292?

Upgrade simple-git to 3.32.3 or later.

## Is CVE-2026-28292 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-28292 exists.

## Other vulnerabilities in steveukx simple-git

- [CVE-2026-102828](https://insights.sbomify.com/CVE-2026-102828/): simple-git unsafe-operation guard does not block trailer command configuration (critical 9.2)
- [CVE-2026-6951](https://insights.sbomify.com/CVE-2026-6951/): simple-git is vulnerable to Remote Code Execution (critical 9.2)
- [CVE-2026-102826](https://insights.sbomify.com/CVE-2026-102826/): simple-git allows command execution through unblocked Git configuration includes (high 8.1)
- [CVE-2026-102827](https://insights.sbomify.com/CVE-2026-102827/): simple-git: unsafe-operations plugin bypass via git long-option abbreviation (--receive-p/--exe) -> command execution (residual of CVE-2026-28291) (high 8.1)
- [CVE-2026-28291](https://insights.sbomify.com/CVE-2026-28291/): simple-git has Command Execution via Option-Parsing Bypass (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-28292 and fix it if it is affected.

What it is: CVE-2026-28292 is a critical command injection vulnerability in steveukx simple-git, published on 10 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-28292 exists.

Affected packages and fixed versions:
- simple-git (npm): affected from 3.15.0; fixed in 3.32.3
- simple-git (npm): affected from 3.15.0; fixed in 3.32.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-28292/ (Markdown: https://insights.sbomify.com/CVE-2026-28292/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-28292
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-28292
- OSV: https://osv.dev/vulnerability/CVE-2026-28292

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-28292/
Summaries are generated and may contain mistakes; the official description above is the record.
