CVE-2026-2833 HTTP Request Smuggling via Premature Upgrade
Attackers can smuggle HTTP requests via premature upgrade handling to bypass security controls and hijack user sessions in Pingora proxies.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-2833?
CVE-2026-2833 is a critical vulnerability in https://github.com/cloudflare/pingora, published on 4 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
An HTTP request smuggling vulnerability (CWE-444) was found in Pingora's handling of HTTP/1.1 connection upgrades. The issue occurs when a Pingora proxy reads a request containing an Upgrade header, causing the proxy to pass through the rest of the bytes on the connection to a backend before the backend has accepted the upgrade. An attacker can thus directly forward a malicious payload after a request with an Upgrade header to that backend in a way that may be interpreted as a subsequent request header, bypassing proxy-level security controls and enabling cross-user session hijacking.
Impact
This vulnerability primarily affects standalone Pingora deployments where a Pingora proxy is exposed to external traffic. An attacker could exploit this to:
* Bypass proxy-level ACL controls and WAF logic
* Poison caches and upstream connections, causing subsequent requests from legitimate users to receive responses intended for smuggled requests
* Perform cross-user attacks by hijacking sessions or smuggling requests that appear to originate from the trusted proxy IP
Cloudflare's CDN infrastructure was not affected by this vulnerability, as ingress proxies in the CDN stack maintain proper HTTP parsing boundaries and do not prematurely switch to upgraded connection forwarding mode.
Mitigation:
Pingora users should upgrade to Pingora v0.8.0 or higher
As a workaround, users may return an error on requests with the Upgrade header present in their request filter logic in order to stop processing bytes beyond the request header and disable downstream connection reuse.
Weakness: CWE-444
Which versions are affected by CVE-2026-2833?
3 open source packages ship an affected version, including pingora-core. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
pingora-core crates.io | All versions | 0.8.0 |
pingora-core crates.io | All versions | 0.8.0 |
pingora-core crates.io | From 0.0.0-0 | 0.8.0 |
Products include Cloudflare Pingora.
How do I fix CVE-2026-2833?
Upgrade pingora-core to 0.8.0 or later.
Is CVE-2026-2833 being exploited?
There is no known exploitation of CVE-2026-2833 in the wild and no public exploit code.
Other vulnerabilities in https://github.com/cloudflare/pingora
Sources
Also known as GHSA-xq2h-p299-vjwv, RUSTSEC-2026-0033.