{"answers":{"affected":"4 open source packages ship an affected version, including @ckeditor/ckeditor5-html-support and ckeditor5. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-28343 in the wild and no public exploit code.","fix":"Upgrade @ckeditor/ckeditor5-html-support to 47.6.0 or later.","what":"CVE-2026-28343 is a medium-severity cross-site scripting vulnerability in ckeditor5, published on 5 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-28343 and fix it if it is affected.\n\nWhat it is: CVE-2026-28343 is a medium-severity cross-site scripting vulnerability in ckeditor5, published on 5 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-28343 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @ckeditor/ckeditor5-html-support (npm): affected from 29.0.0; fixed in 47.6.0\n- @ckeditor/ckeditor5-html-support (npm): affected from 29.0.0; fixed in 47.6.0\n- ckeditor5 (npm): affected from 29.0.0; fixed in 47.6.0\n- ckeditor5 (npm): affected from 29.0.0; fixed in 47.6.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-28343/ (Markdown: https://insights.sbomify.com/CVE-2026-28343/index.md)","id":"CVE-2026-28343","markdown":"https://insights.sbomify.com/CVE-2026-28343/index.md","name":"CVE-2026-28343","record":{"aliases":["GHSA-jrqm-vmqc-gm93","UBUNTU-CVE-2026-28343"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"JavaScript rich-text editor","requires_auth":"low_privilege","summary":"Attackers can execute unauthorized JavaScript via crafted markup in CKEditor 5 if unsafe General HTML Support configuration is used.","user_interaction":"not_required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"ckeditor5","vendor":"ckeditor"}],"cvss":{"score":6.4,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"CKEditor 5 is a modern JavaScript rich-text editor with an MVC architecture. Starting in version 29.0.0 and prior to version 47.6.0, a cross-site scripting (XSS) vulnerability has been discovered in the General HTML Support feature. This vulnerability could be triggered by inserting specially crafted markup, leading to unauthorized JavaScript code execution, if the editor instance used an unsafe General HTML Support configuration. This issue has been patched in version 47.6.0.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"CKEditor: Cross-site scripting (XSS) in the HTML Support package","id":"CVE-2026-28343","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2026"},"n_packages":4,"n_references":3,"next":{"headline":"lxml_html_clean: CSS @import Filter Bypass via Unicode Escapes","id":"CVE-2026-28348"},"packages":[{"ecosystem":"npm","fixed":["47.6.0"],"introduced":["29.0.0"],"last_affected":[],"package":"@ckeditor/ckeditor5-html-support","purl":null,"source":"GHSA-jrqm-vmqc-gm93"},{"ecosystem":"npm","fixed":["47.6.0"],"introduced":["29.0.0"],"last_affected":[],"package":"@ckeditor/ckeditor5-html-support","purl":"pkg:npm/%40ckeditor/ckeditor5-html-support","source":"GHSA-jrqm-vmqc-gm93"},{"ecosystem":"npm","fixed":["47.6.0"],"introduced":["29.0.0"],"last_affected":[],"package":"ckeditor5","purl":null,"source":"GHSA-jrqm-vmqc-gm93"},{"ecosystem":"npm","fixed":["47.6.0"],"introduced":["29.0.0"],"last_affected":[],"package":"ckeditor5","purl":"pkg:npm/ckeditor5","source":"GHSA-jrqm-vmqc-gm93"}],"prev":{"headline":"OliveTin: Unauthenticated Denial of Service via Memory Exhaustion in PasswordHash API Endpoint","id":"CVE-2026-28342"},"products":["ckeditor5"],"published":"2026-03-05","related":[{"cvss_score":6.5,"headline":"Regular expression Denial of Service in Markdown plugin","id":"CVE-2021-21254","kev_date_added":null,"published":"2021-01-29"},{"cvss_score":5.1,"headline":"CKEditor 5 has Cross-site Scripting vulnerability in the clipboard package","id":"CVE-2024-45613","kev_date_added":null,"published":"2024-09-25"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-03-19","vendors":["ckeditor"]},"summary":"Attackers can execute unauthorized JavaScript via crafted markup in CKEditor 5 if unsafe General HTML Support configuration is used.","url":"https://insights.sbomify.com/CVE-2026-28343/"}