# CVE-2026-28343: CKEditor: Cross-site scripting (XSS) in the HTML Support package

> Attackers can execute unauthorized JavaScript via crafted markup in CKEditor 5 if unsafe General HTML Support configuration is used.

- **Severity:** Medium 6.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Mar 2026
- **Updated:** 19 Mar 2026
- **Also known as:** GHSA-jrqm-vmqc-gm93, UBUNTU-CVE-2026-28343

## What is CVE-2026-28343?

CVE-2026-28343 is a medium-severity cross-site scripting vulnerability in ckeditor5, published on 5 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

CKEditor 5 is a modern JavaScript rich-text editor with an MVC architecture. Starting in version 29.0.0 and prior to version 47.6.0, a cross-site scripting (XSS) vulnerability has been discovered in the General HTML Support feature. This vulnerability could be triggered by inserting specially crafted markup, leading to unauthorized JavaScript code execution, if the editor instance used an unsafe General HTML Support configuration. This issue has been patched in version 47.6.0.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-28343?

4 open source packages ship an affected version, including @ckeditor/ckeditor5-html-support and ckeditor5. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@ckeditor/ckeditor5-html-support` | npm | From 29.0.0 | 47.6.0 |
| `@ckeditor/ckeditor5-html-support` | npm | From 29.0.0 | 47.6.0 |
| `ckeditor5` | npm | From 29.0.0 | 47.6.0 |
| `ckeditor5` | npm | From 29.0.0 | 47.6.0 |

Products: Ckeditor Ckeditor5.

## How do I fix CVE-2026-28343?

Upgrade @ckeditor/ckeditor5-html-support to 47.6.0 or later.

## Is CVE-2026-28343 being exploited?

There is no known exploitation of CVE-2026-28343 in the wild and no public exploit code.

## Other vulnerabilities in ckeditor5

- [CVE-2021-21254](https://insights.sbomify.com/CVE-2021-21254/): Regular expression Denial of Service in Markdown plugin (medium 6.5)
- [CVE-2024-45613](https://insights.sbomify.com/CVE-2024-45613/): CKEditor 5 has Cross-site Scripting vulnerability in the clipboard package (medium 5.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-28343 and fix it if it is affected.

What it is: CVE-2026-28343 is a medium-severity cross-site scripting vulnerability in ckeditor5, published on 5 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-28343 in the wild and no public exploit code.

Affected packages and fixed versions:
- @ckeditor/ckeditor5-html-support (npm): affected from 29.0.0; fixed in 47.6.0
- @ckeditor/ckeditor5-html-support (npm): affected from 29.0.0; fixed in 47.6.0
- ckeditor5 (npm): affected from 29.0.0; fixed in 47.6.0
- ckeditor5 (npm): affected from 29.0.0; fixed in 47.6.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-28343/ (Markdown: https://insights.sbomify.com/CVE-2026-28343/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-28343
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-28343
- OSV: https://osv.dev/vulnerability/CVE-2026-28343

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-28343/
Summaries are generated and may contain mistakes; the official description above is the record.
